Solved

Browse and Restore grayed out

  • 27 September 2021
  • 23 replies
  • 243 views

Userlevel 2
Badge +11

The problem is that the Browse and Restore field is greyed out when trying to recover, for example, e-mail (mailbox backup) from previous backups.

Exchange agent is configured in the environment. The client has a configured DAG.

I know that in the case of Mailbox Exchang, it is not possible to do Browse and Restore from Job

SP20.67

 

 

icon

Best answer by Mike Struening 12 November 2021, 23:53

View original

23 replies

Userlevel 7
Badge +14

Hi @kszaf 

Browse and Restore by job is not supported for Exchange Mailbox Agent.

Browsing and Restoring Messages Using the Exchange Mailbox Agent

You can browse for the items that you want to restore from the Content tab (for the entire subclient) or from the Mailboxes tab (for individual mailboxes). In these procedures, the browse is initiated from the Content tab.

Thanks,

Stuart

Userlevel 2
Badge +11

Currently, Browse and Restore does not work in accordance with the screen - from task 34154

 

Userlevel 7
Badge +23

@kszaf , can you clarify the issue?  It sounds like you are aware that it is not possible to do Browse and Restore from Job Exchange Mailbox.

Do you have a job failing or do you need an alternate means to do the restore?

Userlevel 2
Badge +11

@Mike Struening clearly, I see the same problem trying make browse and restore from SQL Serwer from backup history. I think it s not working because is job type > transaction logs 

 

Userlevel 2
Badge +11

For all jobs. I click on Commserve view jobs hisotry and browse and restore grey out 

 

Userlevel 7
Badge +23

@kszaf have you tried this method via the docs?

https://documentation.commvault.com/commvault/v11_sp20/article?p=29021.htm

It looks like you are trying job based restore which is not supported.

Userlevel 2
Badge +11

Hi @Mike Struening - sorry i don’t attache screen in previous massage:
 

 

Userlevel 7
Badge +23

Restoring by Job Id for this agent is not supported, you’ll need to use this method:

Restoring Mailboxes, Mailbox Items, Messages or Public Folders Using the Exchange Mailbox Agent

Applies to: User Mailbox, and Journal Mailbox

Note: In case of public folders, all the public folder data can be browsed from the user mailbox subclient level.

Restore a mailbox, a mailbox item (such as a folder, a contact, or a calendar entry), or a message.

Procedure

  1. From the CommCell Browser, expand Client Computers > client agent set.
  2. On the Content tab, right-click the subclient, and then click Browse and Restore.

    The Browse and Restore dialog box appears.

  3. Click View Content.

    The Client browse window appears.

  4. Do one of the following:
    • To restore a mailbox, select a mailbox in the left pane.
    • To restore a folder, expand the mailbox, and then select the folder.
    • To restore a message, in the right pane, select the appropriate message.
    • To restore a message that has an attachment, select a message that has paper clip icon.
    • To restore a public folder, in the left pane, expand All Public Folders, and then select the public folder.
  5. Click Recover All Selected.

    The Restore Options for All Selected Items dialog box appears.

  6. From the Destination Client list, select the name of the Exchange Mailbox client computer.
  7. Select To Mailbox.
  8. Click OK.
Userlevel 2
Badge +11

@Mike Struening 

Thanks for your time!

Browse and restore working normal from subclient position - you have right of course that for exchange is only way > https://documentation.commvault.com/commvault/v11_sp20/article?p=29021.htm

But its look strange because for all jobs browse and restore not working from job history position, previously it s working - of course, excluding exchange, which works only under subcient position. 

 

 

Userlevel 7
Badge +23

Right, the behavior seems off if you aren’t aware of the caveat!

Userlevel 4
Badge +9

Hello guys,

I have overtaken this case from Kinga.

This is, how it looks like:

  1. The Customer views a backup history of whole CommCell environment.
  2. The Customer right clicks on any job - Browse and Restore option is available.
  1. The Customer right clicks any Exchange Mailbox job - Browse and Restore option is not available.
  1. Then the Customer right clicks any other job - Browse and Restore option is not available any more.

The Customer’s CommServe is running 11.20.73

However, we have noticed exaclty the same situation on different CommCell (CommServe 11.24.7).

Once we right click any Exchange Mailbox job, Browse and Restore option is not available any more for any other job.

What do you think, guys? Is it normal behavior?

Refresh View option does not help, but if we close the Job History window and open it again, Browse and Restore is available for other jobs untill we right click any Exchnge Mailbox job again.

Rgds,

Kami

Userlevel 7
Badge +23

@Kamil W , Browse and Restore via Job Id is not available for Exchange Mailbox; this is normal.

Userlevel 4
Badge +9

@Mike Struening Thanks for your reply.

 

I do agree with you. However, the problem conserns other clients as well.

I have made a quick video, just to give you some more details.

The video was made on CommServe running 11.24.3 but I can also see the same behavior on other CS running different versions, i.e. 11.20.x, 11.25.x

 

Here’s the video:

 

Rgds,

Kamil

Userlevel 7
Badge +23

First of all, THANK YOU for making a VIDEO for this!!!  EXTREMELY helpful.

This is 100% not working as expected then.  Looks like some gui caching problem.

Can you open a support case for this and share the incident number here once you do?

Userlevel 4
Badge +9

Hi @Mike Struening ,

You’re welcome :)

Here’s the case: https://ma.commvault.com/Case/Details/211021-244

Rgds,

Kamil

Userlevel 7
Badge +23

Great!  I can also see it was already sent up to development :nerd:

Userlevel 4
Badge +9

Hi @Mike Struening 

Yes, I was expecting that, to be honest. ;)

Rgds,

Kamil

Userlevel 7
Badge +23

Hi @Mike Struening 

Yes, I was expecting that, to be honest. ;)

Rgds,

Kamil

Same!

Userlevel 4
Badge +9

Hi guys!

As I can see, Support Team provided a hotfix.

Once I get the feedback from the Customer, I’ll let you know, how it goes.

Rgds,

Kamil


From: Nutan Pawar G <npawarg@commvault.com>

 

Hi Kamil,

 

Good Day!

 

Please download the latest updates on the setup and install them. After that install this GUI update on the client where Commcell UI is installed (CS). Browse from the Commcell UI should work fine. Let us know if you have any questions.
 

The details of the request are as follows:

Release v11
BuildID 1108108
FormID 4765
Developer mswetha
Minimum version 11.20.73
Summary Issue with Browse and Restore option from Job History level
MR N/A
Applicable-packages CommCellConsole; CVGxGUI
Customer Rzadowe Centrum Legislacji
Link [Expiry: 12/04/2021] UpdateBundle_Build1108108_Form4765

Please install the latest Maintenance pack for [11.20.73] (if available) before installing this Update Bundle.
Click here for more information.

 

 

 

 

Thanks & Regards,

Nutan Pawar G

Technical Specialist: Server

 

Support (INDIA): 1800-419-2951

Support (International): https://ma.commvault.com/Support/TelephoneSupport

---

 

Userlevel 7
Badge +23

Thanks for the update, @Kamil W !

Userlevel 7
Badge +23

@Kamil W , @kszaf has the customer applied and confirmed all is working?

I see the case is Archived, so I would advise responding to keep it alive:

Dev provided a GUI update to install on the CS.

Need to download the latest updates on the setup and install them. After that install this GUI update on the client where Commcell UI is installed (CS). Browse from the Commcell UI should work fine. Let us know if you have any questions.


The details of the request are as follows:

Link [Expiry: 12/04/2021] UpdateBundle_Build1108108_Form4765
Please install the latest Maintenance pack for [11.20.73] (if available) before installing this Update Bundle.

Userlevel 4
Badge +9

Hi @Mike Struening ,

Sorry for my late reply. I didn’t have any feedback from the Customer.

I can confirm that the fix did work.

Rgds,

Kamil

Userlevel 7
Badge +23

Appreciate the confirmation!

Reply