Commserve not reachable from client while onboarding

  • 13 October 2021
  • 11 replies

Userlevel 3
Badge +10

Hello, Everyone.

I have a REDHAT linux 8.3 client i have been trying to onboard for a while (Trying to install SP22). 

It gets to the SERVER/GATEWAY name, I enter the commserve name, it tries to reach the commserve but it says SERVER could not be contacted.

I have opened port 8400,8401, 8402 and 8403 for two-way and one-way but connection ends up writing the same error.

PINGING and TELNETING works both ways.

I don’t know if there’s any help that can be rendered, please.


Best answer by Mubaraq 12 November 2021, 13:48

View original

11 replies

Userlevel 6
Badge +14

Hi @Mubaraq ,

Does the Linux Client have the Firewall Daemon or other security software running?
When you submit the CS Name, from CMD you can run “lsof -i | grep 840*” to see the status of the connection.

You can check the Install.log, cvd.log, cvfwd.log and maybe SimCallWrapper.log on the client /var/log/commvault/Log_Files/ for any related connection errors.


Best Regards,



Userlevel 3
Badge +10

Hello, @MichaelCapon 

Thank you for offering to help.

So, i tried these steps and still, the issue persists. 

Here is the breakdown of the issue: The client is running an 8.3 Redhat Linux and the Service Pack version we are trying to install is, FR22 MR41, the commserve is running FR17 MR79. We want to install the agent before we upgrade the commserve and media agent to SP22.

Is there any possibility that, the REDHAT LINUX 8.3 is not supported yet, by commvault? Or the problem is, the version we are trying to onboard is higher than the seating commserve. 

The server in question is a critical server and i will be glad if i get some help.

Thank you.


Userlevel 4
Badge +12

Hi @Mubaraq,


RHEL 8.x is supported with SP17. click here to check the system requirements.


Red Hat Enterprise Linux/CentOS 8.x with glibc 2.28.x

Before you install the Commvault software, you must manually install the libxcrypt.x86_64 and libnsl.x86_64 packages on the computer.


I would look at the install.log, installdbg.log, cvd and cvfwd in the /var/log/commvault/Log_Files/  directory 


Gowri Shankar


Userlevel 3
Badge +10

@Gowri Shankar 

Thank you for the prompt response.

I will try this out tomorrow once we reconnect.

Will give update


Userlevel 3
Badge +10


We have successfully onboarded SP17 on the client. 

Now the issue is, the PostGreSQL idataAgent is not showing amongst the packages for selection.

We tried the package on another Linux server, the postGRE was present and suucesssfully installed.

Could there be any reason the POSTGRE dataAgent was not present on the server? How can the issue be resolved?

Please, help.:pray_tone4:

Userlevel 4
Badge +12

@Mubaraq ,


There would be 2 possibilities if the package is not available in the list while performing a local install.


  1. If the package is already installed. Verify this by running commvault status on the server and look for the iDA which is already installed
  2. If it is a custom package and postgre agent was not selected while building the custom package

If the issue still persists, please open a support ticket 

Userlevel 3
Badge +10

@Gowri Shankar 

Thank you for the prompt response.

The package is not already installed and it’s the full package that was downloaded. 

We have the same issue with 3 servers from the same vendor. We have tested with other servers, they are fine.

I am thinking maybe there’s a package missing or something could be blocking it

Userlevel 4
Badge +12

@Mubaraq  - If it is a custom package and if the package is build for selected OS then you may not see the package listed on the other OS. 


Verify if the OS version if its same for all the machines.


Recreate the custom package or download the entire package and retry



Userlevel 3
Badge +10

Hi, @Gowri Shankar 

The package worked on some of the servers.

The issue is specific to servers from the same vendor. We have tried with same OS versions on the different systems. The package worked for the ones from our end but it didn’t show the postgre iDA for the ones from the vendor. I am thinking it’s a thing from the vendor’s environment.

I will appreciate any help i can get.

Userlevel 3
Badge +10

Hi, All

We were able to resolve the issue.

We tried the installation using the root, instead of the super user account we’ve been trying to use.

The postgreSQL iDA appeared and we were able to install & configure it for backup.

Userlevel 7
Badge +23

Thanks for sharing!  I moved the Best Answer to your reply.