Solved

Error: MAPILogonEx failed

  • 5 November 2021
  • 15 replies
  • 111 views

Userlevel 3
Badge +8

Hello Commvault Community, 

 

Today I have a problem with Exchange 2010 operations, and more specifically for the Outlook 2013 application.

When deleting e-mails from an archived mailbox, an error appears:


---
"Mailbox [<Mailbox Name>], Skip / Failure Reason [Error: MAPILogonEx failed, reason:> [MAPI_E_LOGON_FAILED (0 × 80040111)] <, Please verify that the profile this product created can log on to its associated mailbox using the Exchange Client Software. If this software is not currently installed, log on to the Exchange Server using this product's Exchange Account.] "
---


This is probably an outlook on access node problem, I just don't know what. Outlook 2013 × 64 is installed on Exchange 2010.

At first I thought that "Disabling MAPI Over HTTP" would solve the problem, but this is Exchange 2010, not 2013. Interestingly, the mechanism for outlook 2010 works, but does not work for outlook 2013.

 

In the attachment I am sending the content of two logs that record the behavior of the processes for JobID ended with an error.

 

In the "CVMailCleanUp.log" log you can see the following entries:
---
2176 eb0 11/05 12:21:41 3155306 Service account [xyzDOMIAN \ cv-exchange]
2176 eb0 11/05 12:21:41 3155306 physicalClientName [cv-outlook2]
---
---
2176 13bc 11/05 12:22:00 3155306 Current Exchange version for service account [cv-exchange] = 14
2176 13bc 11/05 12:22:00 3155306 Profile [cv-exchange] is used for this job
2176 13bc 11/05 12:22:00 3155306 Could not logon using the profile cv-exchange (MAPI_E_LOGON_FAILED (0x80040111)).
2176 13bc 11/05 12:22:00 3155306 Failed to logon to MAPI profile cv-exchange
2176 13bc 11/05 12:22:00 3155306 Failed to attach MAPIProvider object
2176 13bc 11/05 12:22:00 3155306 Mailbox [VAT-Correspondents] Cleanup Statistics: Stubbing Status: [failed], Processed Folders (Stubbing): [0], Failed Items: [0], Stubbed Items: [0] , Deleted Items: [0], Skipped Items: [0], Space Saved: [0] Bytes, Pruning Status: [], Folders Processed (Pruning): [0], Folders Failed (Pruning): [0], Failed Items (Pruning): [0], Pruned Items: [0], Time To Process (Total): [0.026771] seconds, Time To Process (Stubbing): [0.006851] seconds, Time To Process (Pruning): [0.000000] seconds
2176 13bc 11/05 12:22:00 3155306 ExAgentController :: CompleteData () - Agent [cv-outlook2_Remote0] Received Status [failed] for data [EA572BA9XB929X443AX904DX342E52D02ED5] from worker [1]
---

That is
1. Service account [xyzDOMAIN\ cv-exchange]
2. cv-exchange profiles

 

Could this be the reason why the task ends with such an error? If my track is wrong, where can I find the cause of the problem? I am asking because I have not received an answer from the client yet.

 

Version: 11.25.2

 

I am asking for help in solving the described problem. 

 

Thanks & Regards,
Kamil

icon

Best answer by Mike Struening 6 December 2021, 20:29

View original

15 replies

Userlevel 7
Badge +23

Hi @Kamil !

This is likely an issue between the Outlook profile and what the Mailbox is configured to use in CV.

Can you check the Outlook profile credentials/config and compare it to the MB profile configured in CV?

Userlevel 4
Badge +6

Hello @Kamil 

If you login to the server where the agent is installed (access node) as that service account ‘cv-exchange’ open control panel → mail.

You should see ‘cv-exchange’ profile but it might be corrupt. Try deleting it and click add to create a new profile (make sure at the end click advanced and uncheck “use cached mode”. Make sure you name it exactly the same cv-exchange. Once complete try and again and let us know the outcome.

Userlevel 3
Badge +8

Hello,

Thank you for the tips you sent.

 

In the attachment I am sending two screenshots from the Commvault level and from the Control Panel level on the Access Node. (image_001-002.png)

 

I asked the Customer to check the account with the "Use Cached Mode" option unchecked as you recommended.

 

I'll send you a message with the results when I know them.

 

Regards,
Kamil

Userlevel 3
Badge +8

Hello Guys,

 

The client checked "Use Cached Mode" without selecting the option and during the backup task he got an error - image_003.png.

E-mail deletion is successful, but it doesn't actually delete anything.

 

Any ideas?

 

Thanks,
Kamil

Userlevel 7
Badge +23

I can’t find anything regarding that error.

If @Scott Reynolds doesn’t have any ideas either, I would open a support case.

Userlevel 4
Badge +6

@Kamil 

Use cached mode should be unchecked. But it sounds now that the job is successful however it just does not delete messages? This would be tied to the cleanup policy that is configured. If the rules look right to you (check the rules for date/size etc) and the message meets these rules without cleanup up make sure you can see it when you perform a browse and restore.

If those are checked and it looks okay go ahead open a case and support can investigate.

Userlevel 3
Badge +8

Hello @Mike Struening @Scott Reynolds

 

We will check it and let you know. Please tell me what could be caused by the error during the archive job, is it an expected message?

 

Regards,
Kamil

Userlevel 3
Badge +8

Hi Guys,

 

The message I received:

Delete job do not show error but does not delete anything.

The problem may be that there is an additional archive mailbox for this mailbox.

 

Do you have any ideas on how to tackle this problem further? If not, i will escalate this case to support.

 

Regards,
Kamil

Userlevel 7
Badge +23

I’ll defer to @Scott Reynolds , though if he advises creating a case, then that’s the best action forward :nerd:

Userlevel 4
Badge +6

@Kamil  Archive mailbox is fine that should not be an issue but its most likely configuration on cleanup policy. If those looks fine to you opening a case would be best.

Userlevel 3
Badge +8

Hello, 

I escalated this thread to Commvault support.
Case number: Incident 211116-348

 

I will keep you posted on the progress

 

Regards,
Kamil

Userlevel 7
Badge +23

Thanks, @Kamil !

Userlevel 7
Badge +23

For everyone’s benefit, I’m sharing the latest action from the case (though not closed just yet):

Please add the below additional Settings under the Client :

 

1. 

Name : nHTTPProxy

Category : IDataAgent

Type: Integer

Value -1

 

2. 

Name : CreateProcessSpecificProfile

Category : ExchangeArchiver

Type : Integer

Value : 1

 

3. 

Name : nDontDeleteExchangeAutoDiscoverKeys

Category : IDataAgent

Type: Integer

Value -1

 

4. 

NAme : sCASServerName

Category : IDataAgent

Type: String

Value -1

 

Please find the steps in the link for adding additional settings :

 

https://documentation.commvault.com/11.24/expert/8681_adding_additional_setting_from_commcell_console.html

 

Also would request you, While logged in as the user, make sure that the registry setting to disable MAPI over HTTP is configured, steps found here: https://documentation.commvault.com/11.24/expert/28847_disabling_mapi_over_http.html

 

Please let us know if you have any other concerns so that we can check and assist you accordingly.

Userlevel 3
Badge +8

Hello @Mike Struening 

 

Due to the lack of a client update, the thread has been closed. Unfortunately, I haven’t information on what the matter with the described problem looked like.

 

Maybe someday someone will find this thread useful for troubleshooting :)

 

Thanks & Regards,
Kamil

Userlevel 7
Badge +23

Thanks, @Kamil !  I marked the suggestion as the Best Answer for posterity!

Reply