Question

Force setting Snapdiff v1

  • 4 August 2022
  • 7 replies
  • 34 views

Badge +2

Morning,

We’ve recently updated from 11.24.34 to 11.24.52, and are receiving “Unable to start SnapDiff V2 session” events.  I see in the patchnotes for 11.24.49 that snapdiff will now attempt v2 before falling back to v1.  Our infrastructure is setup for Snapdiff v1, is there a global setting I can modify to stop the commserve attempting to use SnapDiff v2?  I was unable to find anything with a search of the documentation.

Thanks.


7 replies

Userlevel 3
Badge +7

Hello @Brendon McGrath 

I am researching this for you but in the meantime can you let me know what version of Netapp you are running?

 

Thank you,
Collin

Badge +2

Hi Collin,

We’re running 9.8P11.  I know v2 is supported for this version, but the storage team aren’t planning to enable it.  I am also aware that only v3 is supported under version 10 and later.  I’m just looking to disable the v2 attempts to reduce the number of alerts we’re seeing.

 

Thanks.

Userlevel 3
Badge +7

@Brendon McGrath 

Thank you for your patience. I found the below additional setting which you can use to disable SnapDiffV2.

Name:                  bUseSnapDiffV2

Category:            iDataAgent

Type:                     Boolean

Created on:        MediaAgent

 

Thank you,
Collin

Badge +2

Thankyou very much @Collin Harper , I’ll give it a try.

For curiosity’s sake, was it mentioned in publically accessible documentation?

I’m new to CommVault, and don’t know all the places to go looking for answers yet.

Badge +2

Option  bUseSnapDiffV2 isn’t showing up for the MediaAgent, just bUseSnapCopy.

Does the option exist for 11.24.52?

Userlevel 7
Badge +15

Yeah, this is most likely a hidden key so it will not show up by default. Just fill it in and give it a try!

Badge +2

Yeah, I noticed it wasn’t stopping me from saving it as a setting.  We’ll see if everything is quieter tonight.

Reply