Solved

Is 4.2.3 the latest supported version of MongoDB?

  • 31 March 2021
  • 7 replies
  • 288 views

Badge +2

Hi

 

Is 4.2.3 the latest supported version of MongoDB? Are there plans to include the recent version?

icon

Best answer by Sunil 31 March 2021, 15:47

View original

7 replies

Userlevel 7
Badge +15

Hi @LLL 

Thanks for the question, checking Documentation for the latest version, FR23 in technical preview supports later versions of MongoDB, up to 4.4.x:

System Requirements for MongoDB

Supported MongoDB Versions

MongoDB version 3.2.x, 3.4.x, 3.6.x, 4.0.x, 4.2.x, 4.4.x, and Percona Server for MongoDB versions 4.2.x, 4.4.x

Note: Starting from MongoDB 4.4, the mongodump and mongorestore utilities must be downloaded separately and copied to the bin path.


If you are running an earlier version of Commvault, these may only support earlier versions of Commvault.

Which version of Commvault are you running and are there any plans to update?

Thanks,

Stuart

Userlevel 5
Badge +11

Hi

If you are talking about MongoDB backup agent, version 4.4.x is already supported.

https://documentation.commvault.com/11.22/essential/99537_system_requirements_for_mongodb.html

 

Thanks

Sunil-

Badge +2

We are currently running commvault v11.22.13 and was going by this article http://kb.commvault.com/article/SEC0019 to manually update MongoDB

Can i use the same process to upgrade to 4.4.X ?

 

 

Userlevel 5
Badge +11

This is not related to MongoDB backup agent, rather the MongoDB installation Commvault uses.

Let me get some detail about it and get back.

 

Thanks,

Sunil- 

Userlevel 5
Badge +11

@LLL 

I’ve checked with the team. The latest we support is Mongo 4.2 as mentioned in the KB article. 4.4 is not certified yet and not advised to upgrade to that version.

 

Thanks,

Sunil-

Badge +1

To follow on from this, I am also looking to implement the update to the MongoDB used by teh Commserve in response to http://kb.commvault.com/article/SEC0019.  

I checked and our Commserve is using MongoDB server version: 4.0.2.

At the top of SEC0019 it says “For MongoDB 4.0, the most recent stable version is 4.0.22.”; however the upgrade steps below specifically refer to upgrading to 4.0.16, including the URL to download 4.0.16.

Should we plan to upgrade to 4.0.16 or 4.0.22?

 

Userlevel 5
Badge +11

@William Brown 

I’ve asked the team to update the KB article to be consistent. You can plan to upgrade to 4.0.22.

 

Thanks,

Sunil-

Reply