Solved

KillMode=none Issue

  • 9 November 2021
  • 8 replies
  • 180 views

Userlevel 4
Badge +9
  • Commvault Certified Expert
  • 69 replies

Hello guys,

I have received the following message from the Customer:

 


Hello,

We observe following alerts on SLES 15.3 servers where Commvault agent is installed (please see below). We observe those alerts in log /var/log/warn .

Commvault Kill-mode set to none in system configuration by default by installer.

Could you please provide requirements of commvault agent regarding this setting, is it allowed to change it? Which Kill-mode values are allowed?

Is this something we should fix/address?

Thank you!

Error example

systemd[1]1: /etc/systemd/system/commvault.Instance001.service:14: Unit configured to use KillMode=none. This is unsafe, as it disables systemd’s process lifecycle management for the service. Please update your service to use a safer KillMode=, such as 'mixed' or 'control-group'.

Support for KillMode=none is deprecated and will eventually be removed.

Service configuration

/etc/systemd/system> cat commvault.Instance001.service

[Unit]

Description=commvault Service

Requisite=cvunlock.service

After=cvunlock.service

#CVSU_Version=1

[Service]

EnvironmentFile=-/opt/commvault/Base/Temp/Galaxy.env

TasksMax=infinity

Type=forking

ExecStart=/opt/commvault/Base/Galaxy start direct -focus Instance001

ExecStop=/opt/commvault/Base/Galaxy stop direct -focus Instance001

RemainAfterExit=yes

KillMode=none

LimitNOFILE=262144

TimeoutSec=900

[Install]

WantedBy=multi-user.target

Alias=commvault.service

Alias=simpana.service

Alias=simpana.Instance001.service


 

I have tried to find any mention about ‘KillMode’ in BOL, but I didn’t find anything that might help me to answer the Customer.

Could you guys help me, please?

Rgds,

Kamil

icon

Best answer by Mike Struening 24 February 2022, 23:48

View original

8 replies

Userlevel 6
Badge +14

Since the Commvault Services are controlled using commands, I’m not entirely sure if a KillMode is required to be set.

Commands: https://documentation.commvault.com/11.24/expert/8546_commands_to_control_services_on_unix_clients.html

 

Let’s see what other community members have to add here.

 

Best Regards,

Michael

Userlevel 4
Badge +9

Hi @MichaelCapon ,

Thank you.

Yeah, let’s let other community members to reply.

Rgds,

Kamil

Userlevel 7
Badge +23

@Kamil W , I’m marking this as solved since we didn’t get any more replies, but if you need further exploration here, I can undo it and we can investigate.

Userlevel 4
Badge +9

Hi @Mike Struening ,

Sorry for my late reply. I was waiting for any response from the Customer.

 

Here’s the message I got from the Customer yesterday:


KillMode was set automatically by commvault installer, we didn’t change it. I sent you alert from log, where system says that this setting is not recommended and will deprecate in future. I just want to understand how to deal with it, maybe
you could recommend which mode to choose?


 

The Customer is getting the following alert:


-------------------- message from log /var/log/warn ---------

systemd[1]1: /etc/systemd/system/commvault.Instance001.service:14: Unit configured to use KillMode=none. This is unsafe, as it disables systemd’s process lifecycle management for the service. Please update your service to use a safer KillMode=,
such as 'mixed' or 'control-group'.

Support for KillMode=none is deprecated and will eventually be removed.

------------------------------------------


Rgds,

Kamil

 

 

Userlevel 7
Badge +23

No apology need @Kamil W !

I unmarked the prior Best Answer.

For this one, I would get a support case created since development is likely going to need to provide input.

Userlevel 4
Badge +9

Hi @Mike Struening ,

Thanks for your reply. 

Yes, I’m gonna open a support ticket ASAP. Once I get any information, I’ll let you know, how it goes.

Rgds,

Kamil

Userlevel 4
Badge +9

Here you go @Mike Struening ,

https://ma.commvault.com/Case/Details/220121-147

Let’s see what support says.

Rgds,

Kamil

Userlevel 7
Badge +23

Sharing Case Resolution:

You can remove this obsolete option from unit file or do nothing. If they leave the option as is the warning message can be ignored as it won’t affect commvault functionalities, or cause any unsafe situations as what the warning message suggest.
I will suggest to remove this KillMode=none from unit file. This will stop the alerts generation itself.

Reply