Question

Max number of Synthetic Full backups (Additional Setting "MaxSyntheticFullJobsForSPolicy")

  • 29 November 2022
  • 7 replies
  • 110 views

Userlevel 3
Badge +7

Hi,

We’re currently looking at a possibility to change the maximum number of concurrent Synthetic Full backups for clients using the same Schedule Policy. The additional setting “MaxSyntheticFullJobsForSPolicy” seems like the perfect solution to this. However, I’m not getting it to work. I added it to the additional settings of the CommServe machine, and even restarted services but they all keep running concurrently.

There is an additional setting “JMSynthFullJobHighWaterMark” that limits the amount of concurrent Synth Fulls, but that’s for the entire CommCell so not really a solution. I tested this additional setting and this one however works correctly. But the “MaxSyntheticFullJobsForSPolicy” additional setting seems to get ignored. 

I’m running LTS version 11.20 on HFP 77. Anyone having the same issue?

Jeremy

 


7 replies

Userlevel 7
Badge +23

@Jeremy , thanks for the post!

This limit is controlled via two different additional settings in conjunction.

First is JMSynthFullJobHighWaterMark which controls the maximum number of synthetic full jobs that can run simultaneously on the commcell:

https://documentation.commvault.com/additionalsetting/details?name=%22JMSynthFullJobHighWaterMark%22&id=4148

ame: JMSynthFullJobHighWaterMark

Category: CommServe

Type: Integer

Value: 50 (default)

 

The second is MaxSyntheticFullJobsForSPolicy which controls the maximum number of Synthetic Full jobs permitted to run concurrently for a single schedule policy:

https://documentation.commvault.com/additionalsetting/details?name=%22MaxSyntheticFullJobsForSPolicy%22&id=4372

ame: MaxSyntheticFullJobsForSPolicy

Category: CommServDB.GxGlobalParam

Type: Integer

Value: 50 (default)

Can you enable both and retest?

Thanks!

Userlevel 3
Badge +7

Hi Mike,

Thanks for the info!

So I enabled both Additional Settings (and restarted CS services).

I ran a new SynthFull on two clients using the same Schedule Policy, but they’re still running concurrently:

Is there a trick to getting this to work?

Userlevel 7
Badge +23

I would expect these to not run concurrently, assuming that’s the same Storage Policy (can’t see the full name).

If so, I’d open a support case to see what’s happening here.

Keep me posted on the case number!

Userlevel 3
Badge +7

Hi Mike,

Yes, they’re using the same Storage Policy. It’s the only I created in my lab environment.

I created the support case you advised. I’ll PM you the case number.

Userlevel 7
Badge +23

Got it, thanks!

Userlevel 1
Badge +2

The setting “MaxSyntheticFullJobsForSPolicy” is only applicable for synthetic full jobs with Automatic schedule pattern. We can get this information added in the documentation of the setting.

Can we confirm what kind of schedule we are using here?

Userlevel 5
Badge +12

Jeremy,

Are you running a bunch of Synth Full jobs at the same time?  Unless there’s a specific use-case, this isn’t really necessary.  It’s better to let them be spread out through Automatic scheduling for more efficient use of your resources.

Thanks,
Scott
 

Reply