Solved

Deploy Standby CommServe Server

  • 12 October 2021
  • 7 replies
  • 54 views

Userlevel 3
Badge +9

Hi there!

 

Could you please address me to the right procedure how to deploy Standby CommServe Server?

 

I have found this page  (https://documentation.commvault.com/11.24/essential/128066_deploying_standby_commserve_server.html), however we have no HyperScale Appliance it is just ordinary Commserve Server

 

So, if I want to deploy Standby CommServe as DR site in case of speed failover, should I deploy the Standby CommServe as written there (https://documentation.commvault.com/11.24/essential/106129_installing_standby_commserve_host.html)

 

In general, is deploying of the Standby CommServe host time consuming process or is it more intuitive task?

icon

Best answer by drPhil 19 October 2021, 09:19

View original

7 replies

Userlevel 5
Badge +12

Hi @drPhil ,

Deploying the DR CS, you have the right link: https://documentation.commvault.com/11.24/essential/106129_installing_standby_commserve_host.html

 

The amount of time it takes will depend on the machine you’re deploying on … In the field i’ve had some really fast installs and some really slow ones too.

For the most of the install duration, it is waiting on the Third Party packages (SQL etc) to install on the server.

 

Best Regards,

Michael

Userlevel 3
Badge +9

Hi @MichaelCapon,

thanks for the contribution. The procedure looks quite friendly and illustrative.

 

Just one thing I am not sure is point 13 and 22 - naming of the Standby CommServe Server.

So, let's say that my production CommServe Server host has name Commvault1.company.com. In point 13 I should specify only the name for the SQL agent of the Standby host? So, should it be different than the name of the SQL database on the main production CommServer Server?

 

In point 22, "Enter the CommServe client name in the Client Name field, and then enter the standby CommServe host name in the Host Name field. The Client Name is the CommServe client installed in Instance001. Note that this is the name used by clients to connect to this CommServe when it is active. The Host Name is the Fully Qualified Domain Name (FQDN) of the standby CommServe host."

Just to be sure, should it be here the host name of the Production CommServer Server (in my example Commvault1.company.com? Or something different just like CommvaultStandby.company.com?

 

Userlevel 3
Badge +9

Hello, I would modify my question. When deploying CommServe Server Standby Host, what should be the hostname and client name for the Standby CommServe Server? Should be the hostname/client name the same as for the production server?

Userlevel 5
Badge +13

Hello, I would modify my question. When deploying CommServe Server Standby Host, what should be the hostname and client name for the Standby CommServe Server? Should be the hostname/client name the same as for the production server?

 

This should be different.

Userlevel 3
Badge +9

Hello, as @Bart wrote, there should be different name for the production and standby CommServe Server.

I put some notes to this task. First of all, if there is no failover installed on the production server, it is mandatory to install failover package at first (https://documentation.commvault.com/11.24/expert/105056_installing_commserve_failover_package_on_production_commserve_host.html). Then, it can be installed standby server (https://documentation.commvault.com/11.24/expert/102847_installing_standby_commserve_host.html).

However, in the documentation there is a quite inaccuracy then. After installing both package and standby server, it is necessary to enable the live sync feature. After then, it is possible to check the default set up. In the documantation there is in "before you begin" paragraph an instruction to verify the setup before the enabling the live sync feature. It was quite consfusing. Otherwise, the installation was successful.

Userlevel 7
Badge +21

@drPhil , I’ll message our documentation team to clear this up!

Userlevel 7
Badge +21

 @drPhil , I’ll message our documentation team to clear this up!

Tagging in @Leo E  and @Jayashree as per @Seema Ghai 

Reply