Question about one of the additional settings


Userlevel 2
Badge +6

Hi Fellas,

 

Has anyone used the key below, is it safe to use? Will it have a negative impact on the server or the application running on it?
I'm thinking of using this because while taking a backup on one of our servers, clbackup and cvfwd processes are using high cpu. Compression+dedupe are on media agent.
By using this key, I aim to limit the max CPU usage of these processes, will the correct usage be as follows?

https://documentation.commvault.com/additionalsetting/details?name=sSDTHeadMaxCPUUsage

 

 

Best Regards.


12 replies

Userlevel 7
Badge +19

Hey @0ber0n !  Thanks for the post!  I’ll ask around internally to see if we’ve had any issues with it (I’m not aware of any).

In the meantime, I’ve moved this to our Share Your Best Practices section as a Conversation.  this consistently gets the most replies and biggest discussion :sunglasses:

Userlevel 2
Badge +5

@0ber0n you can use this key to limit CPU usage on the client and value would be set as 25% if that is desired limitation. Before setting the issue could be Data Readers or Streams, if CPU utilization is very high you may have a scenario where multiple Subclients or a Single Subclient have too many Data Readers causing the issue. I would check this value first before adding the Additional Setting.

https://documentation.commvault.com/commvault/v11_sp20/article?p=10979.htm

Procedure

  1. From the CommCell Browser, expand Client Computers > client > File System > backup_set.
  2. Right-click the subclient and then click Properties.

    The Subclient Properties dialog box appears.

  3. In the Subclient name box, type the name of the subclient.
  4. On the Content tab, add the content to be backed up.
  5. Click Advanced.

    The Advanced Subclient Properties dialog box appears.

  6. On the Performance tab, select one of the following options:
    • Automatically use optimal number of data readers

      Applies to: File system agents such as Network Shares, Hadoop, GPFS, GlusterFS, and LustreFS.

      When you select this option, the software automatically assigns the number of streams or readers required to perform the backup operations. The number of data readers that are assigned are based on the number of nodes configured for the subclient.

    • Number of Data Readers

      Enter the number of data streams in the Number of Data Readers box.

  7. Select the Allow multiple data readers within a drive or mount point check box.
  8. Click OK.
  9. On the Storage Device tab, in the Storage Policy list, click a storage policy name to associate with the subclient.

    Tip: To create a new storage policy, click Create Storage Policy and follow the instructions in the storage policy creation wizard.

  10. Click OK.
Userlevel 2
Badge +6

Hi Mike,

Sounds good, I'm excitedly waiting for news :)

 

Userlevel 2
Badge +6

@0ber0n you can use this key to limit CPU usage on the client and value would be set as 25% if that is desired limitation. Before setting the issue could be Data Readers or Streams, if CPU utilization is very high you may have a scenario where multiple Subclients or a Single Subclient have too many Data Readers causing the issue. I would check this value first before adding the Additional Setting.

https://documentation.commvault.com/commvault/v11_sp20/article?p=10979.htm

Procedure

  1. From the CommCell Browser, expand Client Computers > client > File System > backup_set.
  2. Right-click the subclient and then click Properties.

    The Subclient Properties dialog box appears.

  3. In the Subclient name box, type the name of the subclient.
  4. On the Content tab, add the content to be backed up.
  5. Click Advanced.

    The Advanced Subclient Properties dialog box appears.

  6. On the Performance tab, select one of the following options:
    • Automatically use optimal number of data readers

      Applies to: File system agents such as Network Shares, Hadoop, GPFS, GlusterFS, and LustreFS.

      When you select this option, the software automatically assigns the number of streams or readers required to perform the backup operations. The number of data readers that are assigned are based on the number of nodes configured for the subclient.

    • Number of Data Readers

      Enter the number of data streams in the Number of Data Readers box.

  7. Select the Allow multiple data readers within a drive or mount point check box.
  8. Click OK.
  9. On the Storage Device tab, in the Storage Policy list, click a storage policy name to associate with the subclient.

    Tip: To create a new storage policy, click Create Storage Policy and follow the instructions in the storage policy creation wizard.

  10. Click OK.

Hi Stogs,

 

Thank you for the detailed explanation.

Actually, I have 1 subclient and the Data Reader is 1. There are 2 CPUs on the server. Despite this, clbackup and cvfwd processes use %80 - %90 CPU when taking backups. This makes the server CPU usage 100% along with other applications.

I have attached a screenshot showing this situation below.  In this case, would it make sense to define sSDTHeadMaxCPUUsage = %25?

 

 

Userlevel 2
Badge +5

In that scenario I would recommend the Additional Setting, we just want to prevent it being overrun due to Data Readers. Which in many cases this value is set high causing an adverse impact on the servers CPU and Memory utilization. 

Userlevel 2
Badge +6

Thanks Stogs,

Then I'll just wait for @Mike Struening 's internal research result about it :) If there is no risk, I will use this key.

Best Regards.

Userlevel 2
Badge +5

@0ber0n I work with the Client Team and we would implement this Additional Setting in this type of a scenario, where lowering Data Readers or adjusting for compression or deduplication do not help. No adverse impact with the “sSDTHeadMaxCPUUsage” in place or known issues that would impact backups by adding it to the client.

Userlevel 7
Badge +19

@0ber0n , the internal resource I spoke to is @Stogs :joy:

He’s an absolute legend in Customer Support!

We may get some other community members replying, though you can take his advice as gold!

Userlevel 2
Badge +6

@Mike Struening and @Stogs I made the situation interesting :) 

Thanks guys for the advice and your interest. I’m gonna implement this Additional Setting :)

Best Regards.

Userlevel 7
Badge +19

Great!  Glad to hear it!

Userlevel 2
Badge +5

@Mike Struening and @Stogs I made the situation interesting :) 

Thanks guys for the advice and your interest. I’m gonna implement this Additional Setting :)

Best Regards.

 Always happy to assist! I’m still working on my “Legend” status for the Community have to catch up to Mr. Struening.

Userlevel 7
Badge +19

 

Reply