ERROR CODE [19:857]: waiting on user input [Delete Mount Path]

Userlevel 2
Badge +11

Hi @Jordan @Mike Struening 

I have a question during the topic. 

So i try delete MP - i working with your advice, but also send mail for authorization to admin and i have below error. 


ERROR CODE [19:857]: waiting on user input [Delete Mount Path [ [cvbackup] H:\P_QNAP (MQNWX2_02.08.2021_13.16) from Library - DiskLibQnap ] requested by [ UMO\mjosko.domadm ]]


View Contents returns an empty list.

There seems to be data on the disk as Size on Disk indicates
several / several hundred GB (similarly the size of the folder on the disk).

Despite the empty list of View Contents, the data on the disk was only deleted after
some time. As I can see, there is something else left.

What does the data erasure mechanism depend on?


Best answer by Laurent 18 November 2021, 17:00

View original

28 replies

Userlevel 7
Badge +23

You may still have blocks on that mount path that are deduplicated jobs are utilizing (and these would not show on View Contents).

Is the MP marked as disabled for write?  Is that library part of any deduplicated copies?

If you have access to the SQL studio manager on the CS, below queries can be run to confirm if there are any jobs stuck in the DB for the DDB store.

use Commserv

select * from idxsidbstore

[this will list all stores, identify and make note of the store id for the one you are concerned with].

Next run the following query to list jobs associated to this DDB.

use Commserv

select * from archjobsonstoreinfo where storeid = n

[n = store id for the DDB in question]

Those are the jobs for the STORE, but which jobs are on that mount path is another matter.  If it was marked as ‘do not write’ a while back, then there might only be a few leftovers, but that also assumes the store was sealed at that time to prevent new jobs from writing there (and I don’t want to assume anything).

Let me know what you find and we’ll go from there!

Userlevel 2
Badge +11

Hi @Mike Struening , 

Thanks for time! We check:

use Commserv

select SIDBStoreId,SIDBStoreAliasName from idxsidbstore

0 N/A

1 SIDB_GDP_Virtual_GDP_Virtual_Primary

2 SIDB_GDP_FilesAndDatabase_GDP_FilesAndDatabase_Primary

4 SIDB_GDB_qnap_GDB_qnap_Primary

use Commserv

select * from archjobsonstoreinfo where storeid = 4

Is the MP marked as disabled for write?  Is that library part of any deduplicated copies? - Yes





Userlevel 2
Badge +11

@Mike Struening 

The most confirm for us is  mail for authorization to admin, we never see this when try delete MP


Userlevel 7
Badge +23

@kszaf , are you saying that the SQL query was empty of jobs, but that you are not receiving the admin approval email?

If that is the case, can you confirm you have the mail server setup correctly as per the docs?

  • To send email notifications about the delete operation, you must configure a mail server in the CommCell Console.

    For instructions, see E-Mail Server Configuration.

Userlevel 2
Badge +11

@Mike Struening thanks a lot, i thing I little tangle this case :) 

I start from begging 

I have a request for information on how to properly remove / clean unused / non-existent Mount Path for Disk Library (used by DDB)

After changes and failure of one of the disk resources, there is a need to organize the resources.

The following problems occurred:

Problem 1:

Delete Mount Path reports a problem with sending an email. Alerts via e-mail and test e-mail from the configuration level work correctly.

The analysis of the mail server logs shows that the Mount Path removal workflow does not take into account the login data to the mail server and tries to send the mail without authentication to the mail server. I am asking for verification / confirmation of such behavior.

Is it possible to enable detailed SMTP session logging in order to view communication with the mail server and how?

Can I turn off the need to confirm Mount Path removal by e-mail? Maybe disabling MP help?



Userlevel 7
Badge +23

You should be able to increase debugging in any log file via Process Manager:

I’m asking about the ability to disable the email requirement for removing mount paths and will update you if I hear anything!

Userlevel 2
Badge +11

@Mike Struening maybe you have any information about ability to disable email?

I will be very appreciate for help. 

Userlevel 7
Badge +23

Apologies for the delay.  I asked around and the consensus was that once the feature is enabled, it is there for good.

I would open a support case and let them help with the e-mails not being received.

Share the case number once you do (and I’ll move this to your own thread)!

Userlevel 2
Badge +11

@Mike Struening thanks. 

I check few time retention, also I generate report:

it means that for this MP retention still block delete?

Userlevel 7
Badge +23

IT looks like the drive is not accessible at all.

Can you log onto the Media Agent and ensure the P: drive is accessible and the DiskLibQSnap folder is there?

Userlevel 6
Badge +15

As well as @Mike Struening advice, also check in this mount path’s properties / General tab that the ‘Enable Mount Path’ checkbox is checked, and that the Device Enabled checkbox is also Enabled (in my example, this MP is clearly offline as it’s down) :

As you see, Commvault reports good troubleshooting steps when an issue is encountered.. :smiley:

Userlevel 7
Badge +23

@Laurent , you are such a gem!  Always so helpful and I wanted to be sure to express that to you!!

Userlevel 6
Badge +15

Thank you so much @Mike Struening goes straight to my heart :pray:

Userlevel 2
Badge +11

@Laurent @Mike Struening 

thanks a lot for your help! your are fantastic 

MP on drive P: is not available (disk corruption caused
irreversible data loss) - hence the need to remove the non-existent one

MP on G: and H: drives are available, but also for removal.

Regardless of whether the MP folder exists / does not exist, in both cases I have
problem with MP removal (even with force option with data loss) in
due to the e-mail authorization requirement.

Userlevel 6
Badge +15

hi @kszaf 

So if the mail authorization is a problem for you, maybe you can start the webconsole with a local admin account (internal like cvadmin, or a new admin account you would create with master rights), not some external like active directory or LDAP..).

Then login to the admin webconsole using this account, then go to the worklflow/actions, and you should be able to see this pending MP deletion task, and should be able to approve it.

If you have SSO/automatic login to the webconsole, then, open it, then go to the drop-down menu to Logout. And then it should invite you to login, and you should be able to provide a new login.


Or maybe I did not understand what is the issue you are encountering, so don’t hesitate to re-explain even step by step.

I understand quickly, but sometimes need to be explained multiple times :joy: .

Userlevel 1
Badge +5

The user used for deleting the mount path and user confirming the mount path deletion needs to be different commvault users.

Userlevel 6
Badge +15

Yes @shailu89 , that’s I think the reason why @kszaf at first was asking if this process could be modified in the product to avoid this constraint.

And that also why I provide this workaround as it worked on my side when I needed it. 

Userlevel 2
Badge +11

Ok i delete MP - thanks for your help! @Laurent @shailu89 @Mike Struening 

Maybe you know:

Is there information in the documentation about the possibility of confirmation?
remove MP from Webconsole and / or Commcell Console? I made it
find only entries about the e-mail:

Userlevel 2
Badge +11

Thank you @Mike Struening @Laurent @shailu89  for the information about the possibility of confirming the removal of MP from the level
Webconsole (and Commcell Console).

The unnecessary MP was removed.

The DDB has been cleaned of unnecessary entries.

Problem has been solved.

The following issues arose during the correspondence and testing:

1. Is there information in the documentation about the possibility of confirmation?
remove MP from Webconsole and / or Commcell Console? I made it
find only entries about the e-mail:,

2. A request to verify that the workflow removing MP is correctly using
login data to the mail server set in the Panel

3. Is it possible to refresh the displayed information on DDB (screen below)
without closing and reopening the console? (this is the only method that works,
which I found)

Using the View-> Refresh button does not affect the DDB summaries.

Userlevel 6
Badge +15

Regarding point 3, yes, so far that’s also the only solution I found on my side.

Userlevel 7
Badge +23

Hi @kszaf , I’m back from my week off :-)

Can you clarify the 2 questions for me?  I can talk to our docs team about anything missing or being off, just need to be sure I understand exactly what you’re looking for :nerd:

Userlevel 6
Badge +15

Hi @Mike Struening, hope your week off was a resting one ! :wink:

My opinion about the mail approval thing is that there’s no details or mention about the situation when you’re the one and only admin, with only a single mail address.

Maybe a notice or more details in the Expert doc section would help, or a workaround as suggested to approve from the webconsole.

Userlevel 2
Badge +11

o excellent @Mike Struening i hope you enjoy you week off :) 

so the meaning question is (I know it s sound complicated)

I meant the option to confirm in Workflows> Interactions (and
the equivalent in Webconsole) - as in the screenshot



Userlevel 7
Badge +23

@Laurent and @kszaf , you both helped a lot in clarifying!

So essentially, you want the ability to confirm a deletion via the Workflows>Interactions section.

Is that about right?  I can submit a CMR for that feature.  I agree that it’s an easy thing to miss as the sole admin/e-mail.

Userlevel 2
Badge +11

@Mike Struening  during the topic. Sorry for interrupt, it s compliated 

I am not receiving messages - workflow emails are not
accepted by our mail server when working properly
configuration of mail dispatch for alerts.

Authentication to the mail server is set in the CV configuration
(login password).

In this configuration, alerts and other notifications are sent correctly.

The MP removal workflow reported shipping errors returned
by our mail server - Client host rejected: Access denied.

Analysis of logs and SMTP communication indicate that the workflow does not use
login / password settings and sends e-mails without authentication to the server

Only changes on the mail server (including permission to accept e-mails
without authentication) allowed to receive e-mails regarding MP removal.

However, this configuration of the mail server is not recommended for us, incl
more so that authentication should work.

Due to the fact that both the backup system and the mail server are used
productively, I am not able to make further changes and tests - hence
request for verification (and possible improvement) from the manufacturer.