Solved

Ansible push_servicepack_and_hotfix 101 Response was not success

  • 13 October 2021
  • 5 replies
  • 34 views

Badge +1

Hello,

I am new to CVPySDK and Ansible.

I made successfuly a playbook which installation Agent on Linux machines.

Now I try to update agent (push)  from the commcell.

I use the push_servicepack_and_hotfix method but it it returns an error 101 Response was not success.

How could I have more detail to debug this error ? 

 

TASK [Push Service Packs and Hotfixes] ********************************************************************************************************************************************************************************
An exception occurred during task execution. To see the full traceback, use -vvv. The error was: cvpysdk.exception.SDKException: Response was not success
fatal: [localhost]: FAILED! => {"changed": false, "module_stderr": "Traceback (most recent call last):\n  File \"/root/.ansible/tmp/ansible-tmp-1634128027.0540986-7125-68037601934166/AnsiballZ_commvault.py\", line 102, in <module>\n    _ansiballz_main()\n  File \"/root/.ansible/tmp/ansible-tmp-1634128027.0540986-7125-68037601934166/AnsiballZ_commvault.py\", line 94, in _ansiballz_main\n    invoke_module(zipped_mod, temp_path, ANSIBALLZ_PARAMS)\n  File \"/root/.ansible/tmp/ansible-tmp-1634128027.0540986-7125-68037601934166/AnsiballZ_commvault.py\", line 40, in invoke_module\n    runpy.run_module(mod_name='ansible.modules.commvault', init_globals=None, run_name='__main__', alter_sys=True)\n  File \"/usr/lib64/python3.6/runpy.py\", line 205, in run_module\n    return _run_module_code(code, init_globals, run_name, mod_spec)\n  File \"/usr/lib64/python3.6/runpy.py\", line 96, in _run_module_code\n    mod_name, mod_spec, pkg_name, script_name)\n  File \"/usr/lib64/python3.6/runpy.py\", line 85, in _run_code\n    exec(code, run_globals)\n  File \"/tmp/ansible_commvault_payload_7gc73cgq/ansible_commvault_payload.zip/ansible/modules/commvault.py\", line 351, in <module>\n  File \"/tmp/ansible_commvault_payload_7gc73cgq/ansible_commvault_payload.zip/ansible/modules/commvault.py\", line 338, in main\n  File \"<string>\", line 1, in <module>\n  File \"/root/workspace/playbooks-commvault/venv_cvlt/lib64/python3.6/site-packages/cvpysdk/commcell.py\", line 2096, in push_servicepack_and_hotfix\n    maintenance_release_only=maintenance_release_only\n  File \"/root/workspace/playbooks-commvault/venv_cvlt/lib64/python3.6/site-packages/cvpysdk/deployment/install.py\", line 340, in push_servicepack_and_hotfix\n    raise SDKException('Response', '101')\ncvpysdk.exception.SDKException: Response was not success\n", "module_stdout": "", "msg": "MODULE FAILURE\nSee stdout/stderr for the exact error", "rc": 1}

 

My playbook, login is OK :

 tasks:

    - name: Commvault commcell initialization

      block:

        - name: Login

          commvault:

            operation: LOGIN

            entity: {

              webconsole_hostname: "#####",

              commcell_username: "#####",

              commcell_password: "#####"

            }

          register: commcell

        - debug:

            msg: "Login is done successfully"

      rescue:

        - debug:

            msg: 'Login failed'

 

    - name: Push Service Packs and Hotfixes

      commvault:

        operation: push_servicepack_and_hotfix 

        entity_type: commcell

        commcell: "{{ commcell }}"

        args:

          {

            client_computers: ["la7lnx0001"],

          }

      register: reg_install_job

 

Thanks in advance for your help

JF

icon

Best answer by cgrau 14 October 2021, 14:06

View original

5 replies

Userlevel 1
Badge +3

Hi @cgrau,

Can you verify if the information for running these commands derives from this below page:
→ https://github.com/Commvault/cvpysdk/blob/master/cvpysdk/commcell.py

If not, is there another location you’re pulling the info from? Also, you mentioned you did the push via the CommCell. So this was a Push Update software Job that ran or is there something else?

Regards,
Greg

Badge +1

Hi Greg,

 

Thanks for your answer. Yes, Everything seems in adequation with this documentation.

I try to put a false client name and it returns an another error which say wrong client name. So it seems to have found the client, although I have the error mentionned : 101 Response was not success.

I try to push update from the commcell via this command/ansible playbook.

 

Sincerely,

JF

Userlevel 1
Badge +3

H @cgrau,

There may be more information within UpdateInfo.log on the server and possibly in the messages log as well as to why the Updates failed. I suggest opening a case with Support to have someone review this further.

Regards,
Greg

Badge +1

Hi @Greg Smolen ,

Thanks for your help.

It was a permission problem, the account used has not enough privileges to push and install software on the client.

 

Regards,

 

JF

 

 

Userlevel 7
Badge +19

Thanks for sharing, @cgrau !  I marked your reply as the Best Answer.

Reply