Question

cannot install linux media agent on a CEntos 8


Badge +2

Hello guys,

 

When I try to execute the ./cvpkgadd command on a linux Centos to install a media agent, here is the message I receive :

[root@localhost tmp]# cd Unix/
[root@localhost Unix]# ls
Commvault.app.xml  cvpkgseed  linux-x8664  pkg.xml.description  support
cvpkgadd           detect     pkg.xml      silent_install       version
[root@localhost Unix]# ./cvpkgadd 
Using update installer /tmp/Unix/linux-x8664/LooseUpdates/CU9/linux-glibc2.3-x86_64/installer/newinstall.gz:
[root@localhost Unix]# 

 

Any idea ?

Thanks !


 

 


12 replies

Userlevel 5
Badge +10

Hey @Bloopa,

Couple of things to check.

  1. Can you try set permissions to 777 or 755 on the installation files / directory?
  2. Can you check if libxcrypt.x86_64 and libnsl.x86_64 are installed. This issue sometimes occurs if those packages are missing on the host.
Badge +2

Thank you @Damian Andre 

on the folder I had copied I ran the following commands :

chown -R root:root /packagefolder

chmod -R 755 /packagefolder

 

Do you know why I can’t see the mediaAgent checkbox ? I am using latest COmmvault Version 11.22

[] File System Core
[] File System
[] CommCell COnsole
[] Oracle
[] DB2
[] Developer SDK - Python
[] Index Gateway

 

 

Badge +2

I have tried try to rebuild the package,

v11 Download Manager with Feature Release 22

download packages to install on different computer
select Unix and Linux-x64-x86 checkboxes
select Packages 
choose download location C:DownloadPkg
select Unix Packages
Server 
[x] MediaAgent

File System 
[x] File System Core
[x] File System 

Latest Maintenance release
After that, I have transfered the package on the linux media agent and executed it.

I think I have missed something.

Badge +2

Hope you would have checked it already, if not I would suggest to verify your existing CentOS version with its respective required glibc version..

https://documentation.commvault.com/commvault/v11/article?p=2822.htm

 

 

Badge +2

Thanks @Anuj

COmmvault recommend Red Hat Enterprise Linux/CentOS 8.x with glibc 2.17.x

and I have :

OS : CentOS Linux release 8.3.2011
 

glib version 
Nom          : glibc
Version      : 2.28
Publication  : 127.el8
Architecture : i686
Taille       : 3.4 M
Source       : glibc-2.28-127.el8.src.rpm
Dépôt        : baseos
 

Badge +2

it’ s a Vmware workstation lab. Can it be a Commvault limitation for example if the VM does not have sufficient memory ?

vm spec

SSD, 4 vcpu, 8 GB memory

 

Badge +1

Hi,

Before you install the Commvault software on Centos 8 with glibc 2.28.x , you must manually install the libxcrypt.x86_64 and libnsl.x86_64 packages on the computer.

 

yum install libxcrypt libnsl

 

Regards,

Steve

Badge +2

Hi,

Before you install the Commvault software on Centos 8 with glibc 2.28.x , you must manually install the libxcrypt.x86_64 and libnsl.x86_64 packages on the computer.

 

yum install libxcrypt libnsl

 

Regards,

Steve

 

Thanks Steve,

Here is the ouptut 

[testeur@localhost ~]$ sudo yum install libxcrypt libnsl
[sudo] Mot de passe de testeur : 
Dernière vérification de l’expiration des métadonnées effectuée il y a 4:11:15 le mer. 24 févr. 2021 09:01:22 CET.
package libxcrypt-4.1.1-4.el8.x86_64 is already installed
package libnsl-2.28-127.el8.x86_64 is already installed

Dépendances résolues.

 

and when I run ./cvpkgadd can’t select MediaAgent

 

[] File System Core
[] File System
[] CommCell COnsole
[] Oracle
[] DB2
[] Developer SDK - Python
[] Index Gateway

Badge +2

it’ s a Vmware workstation lab. Can it be a Commvault limitation for example if the VM does not have sufficient memory ?

vm spec

SSD, 4 vcpu, 8 GB memory

 

Hi Bloopa, You need at least 16GB on your vm

Badge +2

it’ s a Vmware workstation lab. Can it be a Commvault limitation for example if the VM does not have sufficient memory ?

vm spec

SSD, 4 vcpu, 8 GB memory

 

Hi Bloopa, You need at least 16GB on your vm

Hi @Anuj I remember that with previous version of Commvault I was able to Install a full lab with limited resources. Is it limited from the new version ? Is there any chance to use my LAB with minimum resources ?

 

 

 

Userlevel 5
Badge +10

it’ s a Vmware workstation lab. Can it be a Commvault limitation for example if the VM does not have sufficient memory ?

vm spec

SSD, 4 vcpu, 8 GB memory

 

Hi Bloopa, You need at least 16GB on your vm

Hi @Anuj I remember that with previous version of Commvault I was able to Install a full lab with limited resources. Is it limited from the new version ? Is there any chance to use my LAB with minimum resources ?

 

 

 

Typically we don’t limit options available based on system resources, so I don’t think its that. I’m not sure why the MA is not appearing without looking at installer logs, but here is a workaround you can try. Just install FS or FS core, and then from the Commvault UI (command center or commcell console), deploy the Media agent from there. It will push the install through the existing FS agent so you won't need to open any additional ports (ssh etc).

Badge +2

it’ s a Vmware workstation lab. Can it be a Commvault limitation for example if the VM does not have sufficient memory ?

vm spec

SSD, 4 vcpu, 8 GB memory

 

Hi Bloopa, You need at least 16GB on your vm

Hi @Anuj I remember that with previous version of Commvault I was able to Install a full lab with limited resources. Is it limited from the new version ? Is there any chance to use my LAB with minimum resources ?

 

 

 

Typically we don’t limit options available based on system resources, so I don’t think its that. I’m not sure why the MA is not appearing without looking at installer logs, but here is a workaround you can try. Just install FS or FS core, and then from the Commvault UI (command center or commcell console), deploy the Media agent from there. It will push the install through the existing FS agent so you won't need to open any additional ports (ssh etc).

Hi  Damian and all guys,

 

Thanks for your answer.

 

I have found what was the issue

just after my fresh CentOs installation I don't specify a hostname, I use the default one localhost.localdomain

when I launch the cvpkgadd I had this 

[x] 192.168.153.13     localhost.localdomain
[] 192.168.122.1     localhost.localdomain

and after, this

if I click next I have only those options :

[] File System Core
[] File System
[] CommCell COnsole
[] Oracle
[] DB2
[] Developer SDK - Python
[] Index Gateway


After changing the hostname on my centos to the real one ma01.lab.local

here is what I have
[x] 192.168.153.13     ma01.lab.local
[] 192.168.122.1     ma01.lab.local

[] File System Core
[] File System
[] MediaAgent
[] Storage Accelerator
[] CommCell Console
[] Documentum
[] Oracle
[] SAP for Oracle
[] SAP for Hana
[] Cassandra
[] SAP for MaxDB
1/5

I don’t understand why but that's what matters.

Reply