Solved

Cloud storage https connection

  • 28 January 2021
  • 1 reply
  • 158 views

Userlevel 3
Badge +10

Hi there,

 

I have successfully added the cloud storage (S3 compatible). However, for the time being I am only able to set up connection based on http protocol. When I want to add a new cloud storage library using https there is the error message failed to do verification.

To move further, I would like to utilize https protocol. I have self signed certificate from my netapp cloud storage S3 compatible - is it possible to allow using it since I dont have CA issued cert? Could Commvault be forced to use a self signed certificate?

 

What I did try was to “Use this additional setting and set its value to 0 to skip the checking of the server's certificate claimed identity for the cloud libraries”, but it didnt help. Is it possible to check using of this settings?

 

Do you have any suggestions for such situation?

 

Thanks for you ideas.

 

 

 

icon

Best answer by Damian Andre 28 January 2021, 15:21

View original

1 reply

Userlevel 7
Badge +15

Hi @drPhil (our first celebrity? :stuck_out_tongue: )

There is a way to use HTTP instead of HTTPS documented here. You should be able to use specific http://<location> in the service host option when creating the cloud library.

 

There is a setting as you mentioned that will disable SSL check for invalid certificates “nCloudServerCertificateNameCheck

It will ignore invalid SSL certificates - double-check it’s in the right location on the right Media Agent being used to access the s3 target. There is a good log file to check out which might help diagnose further called “CloudActivity-cvd.log” on the Media Agent.

 

The only other thing I can think of is that perhaps the storage accelerator is getting in the way, meaning the CommServe is trying to establish the connection rather than the Media Agent. You can try disabling that if the above steps are not working.

Reply