Question

Commvault and SAML authentication

  • 3 March 2021
  • 7 replies
  • 58 views

Badge +1

Hi,

I have configured SAML authentication on the Command center and an ADFS server for a domain.
Everything works but there is one small thing i don’t get to work.
If i logon and enter the username the redirect to the ADFS servers works but, i need to enter the username a second time. Is there an option to send the username with the SAML redirect?
 


7 replies

Userlevel 4
Badge +7

What feature release are you on, it shouldnt be prompting for username the second time.

Badge +1
The version is 11.20.36

This is what i get with the command center:


This is what i get with other applications:
 

 

 
 
Userlevel 6
Badge +14


If i logon and enter the username the redirect to the ADFS servers works but, i need to enter the username a second time. Is there an option to send the username with the SAML redirect?
 

 @Pieter , to clarify, are you saying you enter your username, it redirects you to ADFS where you authenticate, then Command Center is making you re-enter those same credentials?

Or that you enter credentials at command center and have to re-enter at the ADFS redirect itself?

Does this behavior work the same way with your other applications using ADFS?

Userlevel 6
Badge +14

@Pieter , following up to see if you’ve had a chance to look at my post above.

Thanks!

Userlevel 6
Badge +14

@Pieter , gentle follow up to see if you’ve had a chance to look at this.

Badge +1


If i logon and enter the username the redirect to the ADFS servers works but, i need to enter the username a second time. Is there an option to send the username with the SAML redirect?
 

 @Pieter , to clarify, are you saying you enter your username, it redirects you to ADFS where you authenticate, then Command Center is making you re-enter those same credentials?

Or that you enter credentials at command center and have to re-enter at the ADFS redirect itself?Does this behavior work the same way with your other applications using ADFS?
 

 
@Mike Struening 
Sorry for the late answer.

  1. I give in my username on the command center.
  2. The command center redirects to the ADFS login page.
  3. On the ADFS page i need to re-enter the username on the login page.

    With other software like office 365 i don’t need to re-enter my username.
Userlevel 6
Badge +14

No problem, @Pieter !  I unmarked the Best answer accordingly.

To summarize then, we are not passing along the login attempt to the ADFS page.

Unless others have ideas, I would suggest opening a support case for this issue.  Let me know the case number so we can track and update this thread.

Reply