Question

Commvault can't see the documents on the mac

  • 24 September 2021
  • 22 replies
  • 108 views

Userlevel 2
Badge +10

Commvault can't see the documents on the mac, as it would have permission to do on them:
 

 


22 replies

Userlevel 7
Badge +23

Thanks, I’ll follow the case updates!

Userlevel 2
Badge +10

@Mike Struening case now in support > https://ma.commvault.com/Case/Details/211025-192

Userlevel 7
Badge +23

@kszaf , following up on this one.  Did you see what the source errors were for the restore?

Userlevel 7
Badge +23

19:1253 basically means that you’ve had too many issues and hit the maximum restart attempts.

What we need to know is, what errors occurred before that code showed up?  That will tell us the actual problem (and then solution)!

Userlevel 2
Badge +10

@Mike Struening thanks for your time. 

On job I find error > 

Error Code: [19:1253] Description: Number of restarts has exceeded the maximum number allowed [10].

I try standard KB:

https://kb.commvault.com/article/JM0010
https://kb.commvault.com/article/NWK0010

or maybe you have extra tip?

Userlevel 7
Badge +23

Ok, we can start a new thread on this once we have a little more detail.

What’s the displayed error code?  Are you restoring in place or out of place?

Userlevel 2
Badge +10

@Mike Struening 

Now that I have backed up the data, I cannot restore it to the client.
Received failed message for job [3093369], phase [Restore]. "

Userlevel 7
Badge +23

Hey @kszaf , glad to hear part 1 is solved!

Can you clarify on the issue where you can’t do the restore?

Userlevel 2
Badge +10

@Mike Struening problem with see document on Mac is resolve: 

On the Mac CLI , go to the directory where we are unable to browse the selections and run the following command (do a "ls -l" command to make sure that is the directory you are in:


chmod 755 -R *
Also refer -
macOS Mojave Version 10.14: Considerations
https://documentation.commvault.com/11.22/expert/102909_macos_mojave_version_1014_considerations.html

During this topic I have question - after backup date I can t restore them to the client:
Received failed message for job [3093369], phase [Restore]. - maybe you know?

Greetings, 
Kinga 

 

 

Userlevel 7
Badge +23

Thanks!!!  I see you’re already getting solid advice.  I’ll update this thread once it is resolved, assuming you don’t beat me to it!

Userlevel 2
Badge +10

@Mike Struening the case is in support > Incident 211006-192

Userlevel 2
Badge +10

@Damian Andre @Mike Struening @Darwin Allens 

it is possible that the agent does not have disk-wide permissions, only individual folders. Is it possible to change it so that it has access to the entire disk?

Userlevel 2
Badge +10

@Darwin Allens thanks. the same like in the documents -  don,t see. 

 

Badge

@kszaf , From the commcell Expand the MAC client » goto “sub-Client”» test ( which you created ) » Right click » Properties » Content » Browse » user admin » open “downloads “

Let us know if you can view the content for downloads . 

with the above steps check content for desktop as well from commcell 

Badge +1

to be sure, the Commvault software has goven the permission to Full Disk Access?

 

Regards,

Bart

Userlevel 2
Badge +10

@Damian Andre what is means > Can you view content for user admin for directory downloads and desktop?

 

 

 

Badge

Hi Kszaf, 

Can you view content for user admin for directory downloads and desktop ?

Also which account was used to install CommVault on the MAC ? 
 

Userlevel 7
Badge +23

@kszaf , I reached out to one of our Mac experts to chime in here and advise!

Will either respond on their behalf or they will directly.

Userlevel 2
Badge +10

 

@Damian Andre 

fileVualt is disabled and no other disk is present.

It looks more like the agent does not have permission to these folders because he sees others.

Userlevel 2
Badge +10

@kszaf , are you browsing for restores, or to add content?

Want to be sure it’s not just a matter of the data not being backed up yet (vs. browsing to add subclient content not seeing the test folder).

I browsing for backup 

Userlevel 7
Badge +15

Hi @kszaf,

Permissions should not be an issue with the way we are mounting the drive - can’t say 100% but our process typically bypasses security, since we are attaching the disk into a different machine - it has no idea who the users are.

However, encryption would be a problem since the file would be unreadable outside of the operating system. I’m not a Mac expert (we will see if we can get one to comment here) but a quick lookup shows:

If you're using FileVault 2 (OS X Lion and newer), the entire boot partition will be encrypted, which includes your home folder as well as Applications.

 

So it could be that the data cannot be read during a file browse because it is encrypted. It could also be that this folder is mounted on to another drive using a hard/symbolic link or something like that.

Userlevel 7
Badge +23

@kszaf , are you browsing for restores, or to add content?

Want to be sure it’s not just a matter of the data not being backed up yet (vs. browsing to add subclient content not seeing the test folder).

Reply