Solved

Custom package silent install Commvault Welcome Window

  • 16 April 2021
  • 6 replies
  • 46 views

Userlevel 3
Badge +9

Hello,

 

I have created a custom package I launch it with this command :

 

start /wait C:\CustomPackageLocation_Win_FS\WinX64.exe install.xml /silent

all run fine in silent mode except that there is a Window appears and I need to validate the checkbox.

any idea to avoid that this window appear ?

Thanks

 

 

icon

Best answer by Bloopa 16 April 2021, 16:58

Sorry I don’t say that I will use ansible as third part product.

after testing,now it is ok 

I have used this 

Configure the third-party software to run the appropriate installation command.

  • For Windows custom packages:
    • If the package is a self-extracting executable file, use the following command:

      CustomPackageName.exe /silent /install /silent /authcode authcode

 

Thanks to all for your help. I will open another post because I have a question on ansible and commvault.

View original

6 replies

Userlevel 3
Badge +4

Hi Bloopa, 

 

Please can you try the following as 2 /silent switches are required to suppress EULA and allow install silently (unattended)

C:\CustomPackageLocation_Win_FS\WinX64.exe install.xml /silent /install /silent 

Regards
Blaine

Badge

Hi Bloopa,

 

Thank you for posting in this community.  I just tested this on my side and did not get any prompt to accept the license.  I did notice that you were missing the “/play” parameter in the command as described in our documentation though:

 

https://documentation.commvault.com/commvault/v11_sp20/article?p=2042.htm

To install the package in silent mode, run the following command:

start /wait Setup.exe /play install.xml /silent /authcode authcode

Where authcode is the company authorization code, which is required if you did not enter the installation user's credentials when the package was created. To obtain the authorization code, go to Command Center Companies > Company name > General or CommCell > General.

 

Additionally I just wanted to make sure you selected the proper setting when originally creating this package.  Be sure you selected “Save user answers in the custom package” as shown below:

 

 

Please confirm the package was created with this selected and attempt this again with the /play parameter.

 

Let me know how it goes.

 

Regards,

Joe

Userlevel 3
Badge +9

Hi @JBuratti I have created the package by selecting same options like your screenshot but the also the checkbox “ create self extracting executable”.

Userlevel 3
Badge +9

Sorry I don’t say that I will use ansible as third part product.

after testing,now it is ok 

I have used this 

Configure the third-party software to run the appropriate installation command.

  • For Windows custom packages:
    • If the package is a self-extracting executable file, use the following command:

      CustomPackageName.exe /silent /install /silent /authcode authcode

 

Thanks to all for your help. I will open another post because I have a question on ansible and commvault.

Badge

Hi Bloopa,

 

I just tested this again on my side and I believe this has to do with creating that self extracting .exe as when selecting that option and pointing the new self extracting.exe I now also get the license prompt.

Please create the custom package again this time without creating a self extracting.exe  You then need to point the command to the original setup.exe file 

Let me know how this goes

Userlevel 5
Badge +11

Hi @Bloopa 

Great to hear you have resolved the issue with documentation:

Installing a Custom Package Using Third-Party Software

I’ll go ahead and mark your post as Best answer.

Thanks,

Stuart

Reply