Question

EOL Python 2.7.x detected on commserve, is this required by commserve?

  • 22 February 2021
  • 3 replies
  • 35 views

Badge +1

Hi all

As title, do we need Python 2.7.x on commserve?

 

I found nothing in book online mention that but it seems to comes along with commserve install bundle.  I.E. I was referring to this : https://documentation.commvault.com/commvault/v11/article?p=2801.htm

 

This is current triggering our security sensor as Python 2.7.x is EOL

 

BR,

Mario


3 replies

Userlevel 3
Badge +5

Hi Mario

Please would you confirm what service/feature pack you are running on the Commserve?

Later service/feature packs - from SP11 onwards I believe - automatically install Python 3.6, but leave the previous version 2.7 installed in case of any potential dependencies.
Third Party Applications installed by Commvault Installer:

https://documentation.commvault.com/commvault/v11/article?p=121377.htm

Before you take any action I will confirm potential dependencies for Python 2.7, but once these are checked, it is likely this can be safely removed from the Commserve.

Thanks,

Stuart

Userlevel 3
Badge +5

Hi Mario

Thanks for the question, my understanding is Python is used internally on the Commserve, so we will need to retain a version of python. Let me check internally on update options and versions to bring your installation up to date and comply with your security policy.

Thanks,

Stuart

Badge +1

Thanks Stuart for looking into this. 

 

We’re running V11 SP20, please let me know what you can gather about Python 2.7.

 

Thanks

Reply