Question

Error Code: [32:319] Description: Failed to get Archive Files for Oracle Cross-Check.


Badge +6

Hi Guys, 

Maybe you know. 

I have error in environment, Oracle Error - Error Code: [32:319]
Description: Failed to get Archive Files for Oracle Cross-Check.
Source: alzheimer, Process: DataAging

 

but I don t have Oracle 

 


12 replies

Userlevel 4
Badge +8

Hi Kszaf, 

If you reviewing your dataaging.log you will see the cross check and it will state which client it is doing it for. 

For example: 

9376 40c8 04/05 11:04:26 354286 OraCrossCheck::CrossCheckForOraClientAndInstanceLists() - Start Oracle crosscheck for client with clientId=792 instanceId=[305] 9376 40c8 04/05 11:04:26 354286 OraCrossCheck::CrossCheckForOraClientAndInstance() - Start Oracle CrossCheck for jobId=354286 CommCellId=2 clientId=792 instanceIdIt=305 jobControl=0000007CCFD9B950. 9376 40c8 04/05 11:04:26 354286 OraCrossCheck::CrossCheckForOraClientAndInstance() - m_afList->size()=63. 9376 40c8 04/05 11:04:26 354286 OraCrossCheck::RefreshRacInstanceStatus() - remoteexename = SERVERAgent 9376 40c8 04/05 11:04:26 354286 OraCrossCheck::RefreshRacInstanceStatus() - commandLineArgs = RAC_DBSTATUS -a 2:1850 -racins SERVER4 9376 40c8 04/05 11:04:36 354286 OraCrossCheck::RefreshRacInstanceStatus() - Got process rcode [95] 9376 40c8 04/05 11:04:36 354286 OraCrossCheck::RecvOraParams() - Error: OracleRacInstance::getRacInstanceInfo [id 30] after status update failed 9376 40c8 04/05 11:04:36 354286 OraCrossCheck::RecvOraParams() - Using racInstance SERVER4 for crosscheck

Userlevel 3
Badge +5

Hi @kszaf 

This appears to be a failure while checking if there are any Oracle archive files to prune, not really a failure in pruning.

To know why it’s failing exactly, we need to see if DataAging.log file and see if it’s showing any SQL errors.

 

Could you share the DataAging.log file when you see this error?

 

Thanks,

Sunil

Badge +6

Hi @Sunil - thanks I find this 

 

Badge +6

@Sunil maybe I run DDB Maintenance https://documentation.commvault.com/commvault/v11/article?p=8690.htm

Userlevel 3
Badge +5

Hi @kszaf 

Actually, no need to run DB maintenance. Looks like the some updates are not present on your CS.

Which Commvault version you are running on your CommServer? Please share the Feature release and the hotfix pack number.

 

Thanks,

Sunil

Userlevel 4
Badge +8

Hi kaszf, 

That error has nothing to do with the DDB. What it is saying is that there is a database stored procedure for commvault missing. 

Have you recently completed any service pack or hotfix updates ?  

Have a look in you databaseupgrade.log to see if there was a failed db update, and you updateinfo.log to see if the DB was skipped for any reason. 

Might be worth running a repair on the install. 

 

 

Badge +6
  • Software Version: 11 SP20.53
Userlevel 3
Badge +5

Ok @kszaf . The required updates are in 11.20.52. So, as @Blaine Williams suggested, it’s may be worth doing a repair software on the CommServer to ensure the missing updates are installed properly.

 

Thanks,

Sunil-

Badge +6

@Sunil thanks a lot, 

performing repair software on the client that reported the error (server
running commcell and mediaagent) nothing has changed. 

 

 

Userlevel 7
Badge +17

@kszaf , since that didn’t fix it, go ahead and open a support case.  share the number with me so I can track it accordingly.

Thanks!

Badge +6

@Mike Struening this is number of support case - Incident 210719-283

It s a little bit complicated problem. 

Thanks for you help!

Userlevel 7
Badge +17

It happens :joy:

I’m sure you’ve noticed, I love solving this HERE first!

You’re working with Juan who is absolutely awesome.  Looks like he’s getting information from development.  If you get a resolution before I see it, feel free to update the case and mark it as the Best Answer :nerd:

Reply