Solved

Feature Update Install Failure 11.80.23 > 11.80.24

  • 23 September 2021
  • 3 replies
  • 45 views

Badge +1

Greetings!

Attempting to apply a feature update going from 11.23 to 11.24 however the install has failed during the upgrade. 

The Setup installer displays the error code: [Error: Failed to update Web Server(WebServer) with error code 0x80091007] - a few of web searches seem to indicate that a possible hash mismatch may cause this error code - I have verified the authenticode signature of the underlying .msi file as valid.

I have reviewed the install.log file and have not found any other reported failures or errors.

Any advice or tips on where to look next would be appreciated

icon

Best answer by Tim H 27 September 2021, 15:41

View original

3 replies

Userlevel 2
Badge +6

Hi @JSmith 

May be best to raise a support case to check this out as there may be a number of things that cause this. 

Although a particular MSI was mentioned that appears to be the culprit, curious to know which MSI is causing it, as in previous cases we saw the common culprit was  the "VCRedist_2010SP1_x64"

We were able to resolve this by manually downloading/installing “VCRedist_2010SP1” outside off Commvault from Microsoft

Once the MSI was installed, the Feature update was retried and was successful.

 

Badge +1

@Emils -

Thanks for the suggestion - sadly after repairing the installation of Visual Studio 2010 redistributable directly from Microsoft, the error persists - with the same error code - Error: Failed to update Web Server(WebServer) with error code 0x80091007

I am working on getting access to Maintenance Advantage to submit a support ticket. Considering that I have a recent DR backup would it be worth re-installing Commvault on a fresh server and restoring from DR?  

Userlevel 1
Badge +3

Hello @JSmith,

It would be an option to install the matching components on a new server and restoring the DR but Commvault Support would like to help prevent this kind of issue moving forward. You could also check setuptools.log and installtomcat.log to check for errors.

Reply