Solved

Filtering OneDrive content on the local drive


Badge +1

Hello, 

 

In Commvault 11.20 Commcell I have a number of hosts that have user files and folders located on OneDrive attached as a contents of drive C:. As a result of backup job I face the following messages 

 

[C:\Users\user1\dir1\subdir1\file1.pptx] [0x18B 395] Access to the cloud file is denied.

[C:\Users\user1\dir1\subdir2\file2.pptx] [0x18B 395] Access to the cloud file is denied.

etc. 

 

Is there an elegant way to filter these OneDrive content out?

 

 

icon

Best answer by DR92 7 June 2021, 17:35

Hi @Bancal 

 

At present, the moniker filters only OneDrive i.e. it does not filter OneDrive For Business.

With that being said, I believe the original point of your query was a way to elegantly filter these files from being reported, in other words, your end goal is to not have such files to be reported as Failed Files, correct ? 

 

If yes, then a workaround would be to use the CWE rules to skip from reporting, try adding the following rule to see if it solves your problem.

 

 

Thanks

Dhiwakar

View original

11 replies

Userlevel 1
Badge +1

Hi @Bancal 

 

Did you try specifying %OneDrive% as a subclient filter via the Java Console ? 

 

Thanks

Dhiwakar

Badge +1

Hi @Bancal 

 

Did you try specifying %OneDrive% as a subclient filter via the Java Console ?

 

 @DR92 I have this directive in Global filters.

Userlevel 1
Badge +1

Hi @Bancal 

 

So just to clarify, you have added %OneDrive% as a global filter and you’ve either selected the option highlighted in the screenshot below or chosen to have your global filters be included at the subclient level, correct ? In other words, I’m trying to figure out if the Global Filters are being honored.

 

One other thing that you could try is opening GxAdmin.exe (located in the Base folder), click on the tab labelled Logging, increase the value of Debug Level for FileScan to 3 and then check if the following log line in FileScan.log

 

4704  1a50  06/01 14:05:05 1720 CWorkerBasic::ProcessFindFirstItem(141) - Match not possible, LocalScanPath=[C:\Users\Administrator\OneDrive], SourceScanPath=[C:\Users\Administrator\OneDrive]

 

If you have confirmed that you’ve tried the aforementioned steps and still find OneDrive folder isn't being filtered, please let me know and I’ll be happy to troubleshoot this at a deeper level.

 

Thanks

Dhiwakar

Badge +1

Hello @DR92 , 

 

I have global filters configured in the following way. Is that too cumbersome ?

 

Userlevel 1
Badge +1

Hi Bancal 

 

%OneDrive% should suffice. Are you not seeing the filter term take effect ?

Please make sure that the subclient option Include Global Filters is set to either Use Cell level policy or ON 

If you’re still facing issues, feel free escalate this through support.

 

Thanks

Dhiwakar

Badge +1

Hello, 

 

On the Filters tab of the respective subclient I have Use Cell level policy set.

Userlevel 1
Badge +1

Hi Bancal

 

Would it be possible to escalate this ?

 

Thanks

Dhiwakar

Badge +1

Hello @DR92 Dhiwakar, 

 

Of couse I can file a support case. Just one more question to clarify. This directive  %OneDrive% works for both OneDrive (personal) and OneDrive for Business? It is not quite clear from CV docs. 

Userlevel 7
Badge +15

@Bancal , I'll defer to @DR92 on the question, though please share the incident number once you get a case crated so I can follow up accordingly :sunglasses:

Userlevel 1
Badge +1

Hi @Bancal 

 

At present, the moniker filters only OneDrive i.e. it does not filter OneDrive For Business.

With that being said, I believe the original point of your query was a way to elegantly filter these files from being reported, in other words, your end goal is to not have such files to be reported as Failed Files, correct ? 

 

If yes, then a workaround would be to use the CWE rules to skip from reporting, try adding the following rule to see if it solves your problem.

 

 

Thanks

Dhiwakar

Userlevel 1
Badge +1

Hi @Bancal

 

Just following up to see if you’re still facing any issues.

 

Thanks

Dhiwakar

Reply