Solved

Kill the Commvault jobs automatically if it is in waiting/pending state

  • 17 June 2021
  • 5 replies
  • 64 views

Badge +5

Hi Guys,

I want to automatically kill the jobs in job controller, if it is waiting/pending state for more than 24 hours.

I am aware that CV having the feature and it can be enabled under control panel > Job management > Job restart (tab).

 

But the pain area is, we need to enable the option for 30+ job types by individually. 

 

Do we any mechanism (workflow/qcommend) to enable the “Total Running Time” alone for all the job types at one shot.

 

Thanks,

Manikandan

icon

Best answer by Hemant Mishra 21 June 2021, 13:08

@Hemant Mishra ,

 

Thanks for your response and applied the value, but it haven’t killing the jobs as now. 

I assume, the values are in sec and I entered 21600 (6 hours). Do I want to consider any other factors?

 

Mani 

Mani,

The configured value is in minutes. So please fix the value accordingly. Also we need to restart Jobmanager service after making this configuration change.

Hemant

View original

5 replies

Badge

Manikandan

 

I have asked our Development team if it is possible to enable Total Running Time for the entire Commcell. I will update when I hear back from them.

 

This may or may not help you, but the Total Running Time can also be set at the Schedule Policy level. If you edit a scheduled job within the Schedule Policy (incr, Full, Synthetic Full...) and go to the Advanced Button->Job Retry Tab, you will see the option to set a total running time for that particular job schedule. This will apply to all subclients associated to this Schedule Policy for that particular type of backup. 

Badge +1

@Manikandn ,

Jobs with pending state can be controlled with a commcell wide additional setting.

Below is additional setting to automatically kill laptop jobs.

https://documentation.commvault.com/additionalsetting/details?name=%22JMMaxAllowedClientOfflineTimeLaptop%22&id=2266

There is similar setting for server also.

 

In addition, total running time can be configured at the schedule level also. So withone configuration setting, jobs with all agents associated with the schedule get covered.

Hemant

Badge +5

@Hemant Mishra ,

 

Thanks for your response and applied the value, but it haven’t killing the jobs as now. 

I assume, the values are in sec and I entered 21600 (6 hours). Do I want to consider any other factors?

 

Mani 

Badge +5

Manikandan

 

I have asked our Development team if it is possible to enable Total Running Time for the entire Commcell. I will update when I hear back from them.

 

This may or may not help you, but the Total Running Time can also be set at the Schedule Policy level. If you edit a scheduled job within the Schedule Policy (incr, Full, Synthetic Full...) and go to the Advanced Button->Job Retry Tab, you will see the option to set a total running time for that particular job schedule. This will apply to all subclients associated to this Schedule Policy for that particular type of backup. 

Hi Bill,

 

Thanks for your response, awaiting some valuable input from Dev team.

 

Mani 

Badge +1

@Hemant Mishra ,

 

Thanks for your response and applied the value, but it haven’t killing the jobs as now. 

I assume, the values are in sec and I entered 21600 (6 hours). Do I want to consider any other factors?

 

Mani 

Mani,

The configured value is in minutes. So please fix the value accordingly. Also we need to restart Jobmanager service after making this configuration change.

Hemant

Reply