Solved

PostgreSQL Plan


Userlevel 1
Badge +5

Hi everyone

I’ve got a bit of a strange one. I’ve created a Plan and in there I’ve defined PostgreSQL as the backup target.
I’ve run through everything as I need it to be and the plan is successfully created.
However, the schedules don’t run as I get the below error (tried to manually start the schedule too):

 

‘failed to start backups as no eligible subclients were found’

 

If I backup the DB from the subclient level, I have no problems.
 

I’ve not assigned anything in the default created subclient policies, so not sure what else may be the issue here?

icon

Best answer by Meera 21 July 2021, 08:27

Hi Mauro,

 

We have plans to take care of this in a better way for a future SP. 

For sp23, please associate schedule for dumpbased subclients separately from commcell console. 

If fsbased backups are not required, please disable backup activity for the fsbased subclient.

 

Regards,

Meera

View original

7 replies

Userlevel 2
Badge +3

Hi Mauro, 

 

Which service pack is this? While creating plan from command center, did you get an option to select backup target as PostgreSQL agent Or are you talking about associating a plan to the postgresql server instance created? 

 

Regards,

Meera

Userlevel 1
Badge +5

Hi @Meera 

 

We’re on SP23.
When I created the plan, I don’t see an option to select the backup target as a PostgreSQL agent.

I created it as a normal plan and then tried to associate the PostgreSql Server Instance to that.
It sounds like this may be my problem?

 

Regards,
Mauro

 

Userlevel 2
Badge +3

Hi Mauro,

Configuration made was not clear to me, so I was just getting that clarified. There is no problem there.

 

PostgreSQL has two backupsets(dump and fs based) for onpremise client and dump based only for cloud client. Which one are you using - onpremise or cloud? Also, which backupset is the one having issue? 

 

By default, schedules of plan is associated to fsbased backupset subclient only. For Dumpbased backup set, associating to plan will only associate a storage policy, and not a schedule policy. 

 

Regards,

Meera

Userlevel 1
Badge +5

Hi Meera

 

This makes perfect sense now. I’m having the issue on my Dumpbased set.
So schedules for the Dump instance will still need to be configured outside that plan at a subclient level?

Userlevel 2
Badge +3

Hi Mauro,

 

We have plans to take care of this in a better way for a future SP. 

For sp23, please associate schedule for dumpbased subclients separately from commcell console. 

If fsbased backups are not required, please disable backup activity for the fsbased subclient.

 

Regards,

Meera

Userlevel 2
Badge +3

Hi Mauro,

 

Adding info.

For cloud instances, there is dump based backupset only and we do associate the schedules from plan.

 

For on-prem instances, associating schedules to dumpbased and fsbased will initiate both type of backups at same time. This is supported, but may lead of increase in resource utilization  for large production servers. That’s the reason for associating only the fsbased subclient to plan schedule by default. Regular, snap and block level backups are run using fsbased subclient.

 

We have plans to make schedule association a use option or some way to allow user to associate schedule to dumpbased subclients (database groups) from command center itself. We will update documentation when its implemented. If you have access please track CMR 276898 for status

 

Regards.

Meera

Userlevel 1
Badge +5

Thank you so much Meera. That makes sense and has resolved the issue.

 

Reply