Question

Quick access tools


Userlevel 5
Badge +11

All,

Within Commvault console, we use the quick access tools feature a lot.
That’s very handy, and is an added value. (we also use similar things as workflows)
Despite it’s so usefull, it’s also causinng use headaches and spontaneous hair loss.

As long as you use a simple command, it works fine. but as soon as you use “|” , “$” in the oneliner, that becomes problematic. Especially when using powershell, where that is used a lot.
The documentation on quick access tools is very limited, hence my question over here:

What is the official way to use    ‘ , “ , | , & in the command / parameter of the quick access tool. What is the escape character?

 

 

 


5 replies

Userlevel 6
Badge +12

Hi @Bart 

Thanks for the question.

For the benefit of the Community, checking documentation on this: Executing the Workflow Tool from the CommCell Console

“Variable parameters are defined using the $ character which prompts the user to enter the required value during the execution of the application.”

Also 

“… you can use $%CLIENT_NAME%$. %CLIENT_NAME% is a tokenized parameter that automatically retrieves the hostname of the CommServe, MediaAgent or client computer.”

So $ and % are expected to delimit variables or parameters, but as you say, there is no mention of what escape character to use if you need to pass these characters as input to your script or application.

Usually, backslash is expected as escape character, but I will need to check internally to have this confirmed.

Thanks,

Stuart

Userlevel 5
Badge +11

@Stuart Painter I already tried backslash, but that diesn’t work. (was the first thing I tried)

Userlevel 7
Badge +15

Hey @Bart , following up to see if you got an answer here or not?  Might warrant opening a support case if this is not working as expected (and sharing the case number with @Stuart Painter and I :sunglasses: )

Userlevel 6
Badge +12

Hi @Bart 

I have some feedback from Dev on this one, my apologies with the delay, this got lost in my inbox, delay is on me.

Only $ and % are special characters, and we can use \ to escape $.

There is no way to escape %, and any text in between two %’s is considered a Commvault token.

I hope that helps.

Thanks,

Stuart

Userlevel 4
Badge +10

Hi @Bart 

I have some feedback from Dev on this one, my apologies with the delay, this got lost in my inbox, delay is on me.

Only $ and % are special characters, and we can use \ to escape $.

There is no way to escape %, and any text in between two %’s is considered a Commvault token.

I hope that helps.

Thanks,

Stuart

@Stuart Painter would it be possible to get around that by using the ASCII sequence \x25 instead?

Reply