Solved

Replication performance issues

  • 27 July 2021
  • 4 replies
  • 29 views

Userlevel 1
Badge +8

The AuxCopy task for storage policy takes longer than it should, in the zabbix charts we can see that in certain hours the link between locations (200mbps) is not saturated at all (as if replication stopped / slowed down for e.g. 5 hours).

New tasks come and finally replication can take up to ~ 50h (for replication, for example, 2TB - which should be sent in half of this time).

icon

Best answer by kszaf 17 August 2021, 10:53

Thanks a lot for help! @Mike Struening , the solution is setting scheduler every 30 minutes

View original

4 replies

Userlevel 7
Badge +19

@kszaf , those seem to be pretty defined drops, at specific hours.  My initial suspicion is some sort of bandwidth throttling.  Is there any in place on the network side?

Another question for context, what is the link here between?  Is it ONLY between 2 specific media agents (for an aux copy), or are there multiple backups, etc. going between each?

It’s also possible it’s a streams issue, that you have, say, 50 streams and most of them complete at those peaks, though the last few remain (with the job still incomplete) but that doesn’t really explain why the throughput jumps up at almost exactly the top of the hour.

We would need to know more about what jobs are running across this link and how they are scheduled.

Thanks!

Userlevel 7
Badge +19

Hey @kszaf , were you able to collect more contextual details to what you are seeing for us to investigate?

Thanks!!

Userlevel 1
Badge +8

Thanks a lot for help! @Mike Struening , the solution is setting scheduler every 30 minutes

Userlevel 7
Badge +19

Ok, great!  Credited the solution to your reply :nerd:

Reply