Solved

Restore of virtual machine on Tape library-error

  • 14 October 2021
  • 5 replies
  • 44 views

Userlevel 2
Badge +7

Hello,

I have commvault backup server and two media agents, one media agent installed on backup server and other installed on a special machine. I have installed vsa server and FRE server separately on each machine on Citrix virtualization.

Before the backup of the virtual machine was placed on a media agent that is on citrix virtualization.

I have now backed up the virtual machine successfully but to the Tape library via another media agent.

When I do a restore from a virtual machine I have an error

 

Best regards,
Elizabeta

 

 

 
icon

Best answer by Mike Struening 14 October 2021, 16:16

View original

5 replies

Userlevel 7
Badge +21

Hey @elizabeta !

This is happening because the MA lacks the Virtual Server Agent, so the workflow conveniently runs the install, however it failed.

Can you run a manual install of the VSA on that Media Agent, and if it fails, give me the error message and log excerpts?

Thanks!

Userlevel 2
Badge +7

Hello,

Backup VM completed successufully on this media agent. When I do Browse and Restore Full VM, it works without problems.

But, when I do restore just one file
 

an error occurs

I did previous VM backups and there was no problem. The whole server is installed as a separate machine and not on the media agent I used to back up before.

There may be a problem with the FREL machine (File Recovery Enabler for Linux) because granular restore does not work.

Best regards,
Elizabeta

 

 

 

Userlevel 7
Badge +21

Hi @elizabeta , not sure if you saw this:

Can you run a manual install of the VSA on that Media Agent, and if it fails, give me the error message and log excerpts?

Thanks!

Userlevel 2
Badge +7

Hello,

@Mike Struening I saw your reply, but that media agent where they would install everything is in production ..
In the current configuration, everything is installed on the Xen environment as a separate server, so is the FREL server and media agent.
 

Should in this case VSA be installed as a separate server, also FREL??

Thank you!

Best regards,
Elizabeta

 

 

​​​​​​​

Userlevel 7
Badge +21

@elizabeta , whatever Media Agent you are using needs the VSA installed.  

Here’s the docs link and section:

https://documentation.commvault.com/11.21/expert/30829_automatic_configuration_of_mediaagent_as_linux_file_recovery_enabler_frel.html

The machine must have both MediaAgent and Virtual Server Agent packages installed.

Reply