Solved

skipping Global DDB creation.


Badge +3

Storage policy creation wizard asks for storage pool creation and global DDB creation. How to bypass this? I don't want to create a global DDB. Commvault is at V11.23.

icon

Best answer by CypherOne 19 August 2021, 06:47

@Mike Struening , Case ID is 210818-108.

this was the response:

“While creating a storage policy from the CommCell console, earlier version (until FR20) of Commvault had the option to use the libraries directly, whereas from FR21 onward, it is mandatory to create a new or use an existing storage pool and this is working by design as confirmed from our next level team.”

View original

16 replies

Userlevel 6
Badge +13

Hi @CypherOne 

You may need to create a Storage Pool first, with deduplication disabled, then associate storage policies to the pool with more granular configuration.

Please see Configuring a Disk Network Storage Pool with Global Storage for an example. 

Procedure

  1. From the CommCell Browser, expand to Storage Resources > Storage Pools.

  2. Right-click the Storage Pools and click Disk.

  3. The Create New Storage Pool Wizard opens. Follow the instructions in the wizard and use the data that was already gathered.

    In the Enable deduplication on Storage pool page, clear the Enable deduplication check box.

  4. Click Finish to create a disk network storage pool.

    The new storage pool appears under the Storage Pools node.

Result

After the configuration the following entities will be available in the CommCell Console:

  • A disk library will be created and displayed under the Storage node in the disk network storage pool node in the CommCell Console.

  • If a client group was selected, then all the MediaAgents in the client group are automatically shared across the mount paths available in the library, using one of the following transport types:

    • For mount paths with a Network path, the MediaAgents are shared as a network path with Read/Write access using the Regular transport type.

    • For mount paths with a Local path, the MediaAgents are shared with Read only access using the Data Server-IP transport type.

What to Do Next

Thanks,

Stuart

Badge +3

Hi @Stuart Painter ,

 

Thank your for the reply.

So, does it mean that if deduplication is enabled, it will always be Global DDB or will it limited to the particular storage pool? 

Userlevel 7
Badge +19

@CypherOne , what is your goal?  To create a non-Dedupe Storage Policy, or to create Storage Policies that utilize the Global Dedupe SP?

Badge +3

Hello @Mike Struening ,

Couldn’t reply back on time. Was offline.

Unlike old times, is it possible to restrict the Dedupe to storage policy instead of having a Global DDB?

Userlevel 7
Badge +19

@CypherOne are you not seeing the option to just create a stand alone Dedupe Storage Policy?

There’s an option when you create to use a global DDB or not:

https://documentation.commvault.com/11.24/expert/12442_creating_storage_policy_with_deduplication.html

Userlevel 2
Badge +5

@CypherOne  As you walk through the Storage Policy creation wizard, if you uncheck the ‘Use Existing Storage Pool’ option, you can continue through to the deduplication step.
This will create a Stand Alone DDB associated only with this Storage Policy.

If creating a new Copy, select the radio button ‘Use Library’ instead of ‘Use Storage Pool’, and you can go through the regular steps of creating a new copy.

 

If using a Storage Pool, than you will have to have a Global DDB assocaited.

Its worth noting, that if you create a global DDB, and associate only the 1 storage policy with it, than it behaves no differently than a stand alone DDB. 


Cheers,
Jason​​​​​​​

Badge +3

@jgeorges ,

 

Every time i configure a storage policy, it asks me to select or configure storage pool. I don’t get option to select ‘use Library’ as you told earlier. I am using V11.23 and storage policy is for Azure cloud Library.

Userlevel 2
Badge +5

Hi CypherOne,

 

 I ran through the steps for creating a new storage policy on a staging machine for good measure. Step by step I started with “New Storage Policy” > Data Protection and Archiving > Entered a Name (nothing else) > then on the “Do you want to use a Storage Pool” I was able to deselect, hit next, then select a library as seen below.

 

 You aren’t able to deselect the “Use Existing Storage Pool” and move on to library selection? What is it instead you are seeing?

Badge +3

Hi @Vsicherman , I am not getting any option to deselect the use of storage pool.Which version of Commvault and maintenance release are you using?

Userlevel 2
Badge +5

Hi CypherOne,

 

 Interesting! That was on 11.22.XX, I just tested on a 11.24.3 stage and I’m seeing the same results as you! Note the documentation was not changed between 11.22 and 11.24, I’d suggest opening a case for this issue for further investigation:

22

https://documentation.commvault.com/11.22/expert/13808_creating_storage_policy_for_disk_library_or_cloud_library.html

 

24

https://documentation.commvault.com/11.24/expert/13808_creating_storage_policy_for_disk_library_or_cloud_library.html

 

Userlevel 7
Badge +19

@CypherOne , were you able to determine the issue (or open a support case)?

Userlevel 7
Badge +19

@CypherOne , following up to see if you were able to either get this one resolved, or open a case with support.

Thanks!

Badge +3

Hello @Mike Struening , Will be opening a case with support shortly.

Userlevel 7
Badge +19

Great!  I was hoping you would :nerd:

Once you do, share the case number so I can track it accordingly.

Thanks!!

Badge +3

@Mike Struening , Case ID is 210818-108.

this was the response:

“While creating a storage policy from the CommCell console, earlier version (until FR20) of Commvault had the option to use the libraries directly, whereas from FR21 onward, it is mandatory to create a new or use an existing storage pool and this is working by design as confirmed from our next level team.”

Userlevel 7
Badge +19

Thanks, @CypherOne !  I suspected as much.  Things are moving towards storage pools (though ?I wasn’t entirely sure on which FR we started this).

Appreciate your replies!!

Reply