Solved

SP upgrade and Livesync

  • 20 September 2021
  • 5 replies
  • 98 views

Userlevel 3
Badge +7

Good evening all

 

I've never upgraded a Service Pack in a LiveSync configuration. 

I know that you usually run the 'install updates' command on a secondary commserve with the 'do not update db' parameter.

 

In a LiveSync configuration, do you install the Service Pack on each commserve and treat it as the primary during the upgrade or install via command line and 'do not update db'? 

 

Thanks,

Mauro

icon

Best answer by Michael 21 September 2021, 03:02

View original

5 replies

Userlevel 4
Badge +7

Hi @Mauro 

Hope you’re well!

The following article provides an overview on the steps we recommend be followed to achieve this: https://documentation.commvault.com/11.24/essential/105892_installing_feature_releases_on_commserve_livesync_setup.html 

Step 1: Initiate a Maintenance Failover
Step 2: Install the Feature Release On the Production CommServe Host
Step 3: Reset Maintenance Failovers
Step 4: Install the Feature Release On the Standby CommServe Host and SQL Clients

Could you please run thru this and let me know if you have any questions or concerns?
 

Regards,
Chris 

Userlevel 2
Badge +2

Hi @Mauro

 

The steps Chris has shared is the documented procedure which assumes that you prefer not to have an outage (will alow restores \ recalls to continue).

 

An alternative if that is not a concern and you do not mind scheduling an outage an easier way with less complexity \ steps would be:

a) First upgrade the production Commserve instance like you normally would, either via the Commcell console or running the Feature Release (previously called Service Packs) interactively from the downloaded media.

b) Once the production Commserve is upgraded. open the Commcell console, you will see a client group called “CVLiveSync” (Note: this is not the container called “CSLiveSync”, “CVLiveSync” client group will only have your production Commserve client and failover clients as members, so 3 clients if you have 1 standby, the prod Commserve client and the 2 failover instances, prod and standby)

c) Right click that client group “CVLiveSync” [I am assuming your software cache is up to date here] then “All Tasks > Add/Remove Software > Update Software”

 

This will submit an update software job for all 3 clients, the Commserve will report back advising install already completed, the production failover instance will get upgraded, and for the standby, if your Commserve Live Sync configuration was installed correctly, it will actually auto upgrade Instance001 on the standby Commserve and take care of that for you (it knows not to start services or upgrade the database).

 

This makes it much easier to manage upgrades for Commserve LiveSync then what use to be the case, which are the steps you were referencing that were required before. Those steps are no longer required.

 

The steps above also are simpler if you were planning on having an outage for the Feature release upgrade anyway.

 

Let me know if you have any questions on the above.

 

Regards,

 

Michael

Userlevel 3
Badge +7

Good morning Chris and Michael

This is exactly what I was after. Chris, will use the prefered method when the LiveSync is completely up and running.

For now, we were happy with the downtime.

One of the Commserves in my LiveSync setup is unreachable at the moment due to routing.
In this case would I run the FR in the following manner:

a) First upgrade the production Commserve instance like you normally would, either via the Commcell console or running the Feature Release (previously called Service Packs) interactively from the downloaded media.

 

Thanks again.

 

Mauro

Userlevel 2
Badge +2

Hi @Mauro 

 

Thanks for the reply, glad we could help. To answer your question, If one of the passive (standby) nodes is not accessible from the production Commserve you have 2 options:

 

Option 1: Wait until connectivity is restored and follow my original email steps.

This is the simplest method, because if one of the standby servers does not have connectivity to the Commserve no Commserve LiveSync replication jobs will be working anyway, so there is nothing wrong with waiting until it is back online, then upgrading it.

 

Option 2: You could run the install using the media locally on that box upgrading instance002 (the failover instance) that action should initiate the automatic upgrade of the disabled \ inactive Commserve instance001 on the same box if failover on the passive nodes was installed correctly. (See below for what I mean) NOTE: after every upgrade, clients try and reach out to the Commserve they are registered with to inform of the upgrade, so this part will fail but should show up reporting its version correctly once connectivity is restored

 

Some assumptions I am making when providing the options above:

 

Assumption 1: When you installed the standby Commserve, it was able to communicate with the production Commserve at the time and registered itself. (So you have the failover client installed on the standby Commserve listed in the Commcell console)

 

Assumption 2: For standby nodes, you would have followed the steps here during install: https://documentation.commvault.com/commvault/v11_sp20/article?p=102847.htm  note that it involves installing the Failover instance and Commserve instance at the same time, during the same installation. Not like on the production Commserve host where all you would have done is install the Failover instance.

 

This is explained here: https://documentation.commvault.com/commvault/v11_sp20/article?p=105066.htm Steps 6 and 7. This link is when an environment was using some other log shipping  \ high availability method and want to move to Commserve LiveSync.

 

If the standby was already a standby and you installed the failover instance on top, this will not be a correct installation method for the standby Commserve as none of the expected CS LiveSync mappings will have created properly when installing a standby in this way.

 

So if the standby was not installed as per Assumption 2, then I would recommend waiting until you have connectivity restored to the production Commserve between standby and production then completely uninstall and re-install the standby node using the target version the production Commserve is on using the steps here https://documentation.commvault.com/commvault/v11_sp20/article?p=102847.htm and give the same client name you gave for the failover instance previously on this standby node.

 

I apologise for my lengthy replies, I just want to make sure I am giving you the best guidance I can.

 

Please let me know if you have any questions after reviewing the above.

 

Regards,

 

Michael

 

 

Userlevel 3
Badge +7

Hi Michael

You’ve answered exactly what I needed. We are in that scenario right now, but I’ve managed to get everything updated as required.
There was a bit of pressure to get the FR deployed before completing the LiveSync configurations, because we needed to address one of the customer’s requirements.

I’ll definitely be using this as my reference on future deployments and will share with my colleagues too.

Thank you so much again.

Regards,
Mauro

Reply