Solved

SPfile was deleted after Snap


Badge +1

Hello,

since we installed the SP23 Hotfix 7 on our commserve we have the following problem.

After wie make a “Database Online Full Snap” on our Oracle-ASM DB (Linux-Server) the Snap-Job delete the SPfile. No chance to restart the DB.

Why ?

 

Regards

Chris

 

icon

Best answer by Shane S 11 May 2021, 23:08

@Chris_MN

Can you confirm if it is the SPfile that is created before taking snapshot that is deleted upon completion of the backup, or is the backup process deleting the SPfile used to start the database?

There was a patch in 11.22 (Update 139414) to automatically cleanup the SPfile that was created during the snap backup.

 

To prevent cleanup of the SPfile, you can configure the below additional setting on the Oracle client.  

 

Name = DELETE_SPFILE_CTRLFILE_COPY

Category = OracleAgent

Type = String

Value = N

 

https://documentation.commvault.com/11.23/expert/8681_adding_additional_setting_from_commcell_console.html

 

Let us know if this helps.

View original

4 replies

Userlevel 7
Badge +15

Hey @Chris_MN , did this happen immediately after applying 11.23.7 (assuming that’s what you meant)?  As in, do you have working backups up until you applied it, then immediate failures?

Does the job show any error messages?

I’d like to see what I can find in our database if you can share some details, error messages, logs, etc.

 

For the log files we need ClOraAgent.log on the client with debug level 6 (at least) and backup rman log.

Thanks!

Badge +1

@Chris_MN

Can you confirm if it is the SPfile that is created before taking snapshot that is deleted upon completion of the backup, or is the backup process deleting the SPfile used to start the database?

There was a patch in 11.22 (Update 139414) to automatically cleanup the SPfile that was created during the snap backup.

 

To prevent cleanup of the SPfile, you can configure the below additional setting on the Oracle client.  

 

Name = DELETE_SPFILE_CTRLFILE_COPY

Category = OracleAgent

Type = String

Value = N

 

https://documentation.commvault.com/11.23/expert/8681_adding_additional_setting_from_commcell_console.html

 

Let us know if this helps.

Badge +1

Hello,

many thanks to you @Shane S . It looks like the problem was solved with the entry in the oracle-client Additional settings.

Now the spfile and the galaxy-files don't be deleted.

But I think it will be better if those new settings will communicated on a new patch-level.

For our RAC Agent I set this on the physical nodes, right ?


Note: In a cluster environment, you must specify the additional settings on the physical nodes (the client computers), not on the cluster server. For more information, see Configuring Additional Settings in a Cluster Environment.

 

many regards

chris

 

Badge +1

@Chris_MN  

Excellent, glad to hear that did the trick!   And yes, you would configure an additional setting on the properties of each of the physical nodes in the case of a RAC.   

As far as I understand, however, this specific setting should NOT be required as the original SPfile to start the database and the copy of SPfile created during the snap backup should be in separate locations.

Reply