Question

sucessful backups not protecting files The process cannot access the file because it is being used by another process

  • 8 February 2021
  • 30 replies
  • 249 views


Show first post

30 replies

Userlevel 4
Badge +6

@MFasulo  Have to admin that it's getting better and better, but adding in auto remediation would be the next step right ;-)

Shall I open a CMR for the reprocessing of failed files after the job finishes to perform a re-scan that will scan all missed files to identify if they were deleted during the job run? That would remove a lot of false positives from being taking into account.

yes!!   

In regards to the reprocessing:   during file scan we build a collect file.  That collect file is passed to the backup process to protect the files.  What is happening is inbetween the scan and backup, the files disappeared.  The backup will flag that as a specific failure with an appropriate context/error code.  In the screenshot below we flag windows error code 3 (first red box) for path not found (it was in the scan, but when we went to back it up it wasnt there, and the second red box was error code 2, the file is not there.  

In those cases remediation isnt possible, but for other conditions we should explore a retry (I’m almost positive we try again at the end of phase runtime, but ill check with dev)

 

Userlevel 4
Badge +6

The file system backups are showing as successful(no warning) however failing to protect some of the files; I  am wondering why the job is not completing with partial sucess and showing it as a VSS issue.  Is that becuase there are no application specific vss writers for the application and hence quiesing is not working its magic 

  • [C:\Program Files (x86)\BigFix Enterprise\BES Client\__BESData\SiteData.db] The process cannot access the file because it is being used by another process.

 

Correct, and it cant quiese the DB.   How does bigfix recommend protecting the DB?  From there we can help craft a solution

Badge +1

okay so I investigated it further; although the VSS writers were showing as okay; the VSS providers had an additional provider Acronis VSS sw provider

 

and VSS errors on the event log 

12292 during backup

 

Checking with customer now if they have any other backup agent installed and shared the following article for them to review.  

Hello guitarfish,

Thank you for posting this information in our forum.

Did you check if this, after upgrading from Acronis Backup & Recovery 11 to Acronis Backup & Recovery 11.5?

  1. Go to Start -> Run -> regedit.exe and press ENTER;
  2. Navigate to this key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\VSS\Providers\
  3. Check, if you can find at the left part entries below Providers. There should be only one entry.

    Under every condition: Click on every entry and check in the right part, if you can find this entry: "Microsoft Software Shadow Copy provider 1.0". Do not delete this entry!

    For the other entries: Check if you can find the Acronis VSS Provider entry and delete it.

  4. Restart the machine.

 

 

Badge +1

The command ‘vssadmin list providers’ should show what’s available. 


If another provider is set to be the defaults, you can force CommVault to call the windows provider using nUseVSSSoftwareProvider

https://documentation.commvault.com/commvault/v11_sp20/article?p=18457.htm

Badge +1

I did try forcing this using the key however it still failed.  will review the logs further.

Reply