Question

Unable To restore filesystems - cvpysdk - Python

  • 16 February 2021
  • 8 replies
  • 122 views

Badge +2

Hello,

I have some trouble to restore filesystems to a Storage array using the cvpysdk python library, the restore from the Commcell works perfectly.

The commands that i’m using to do a restore is bellow:

commcell = Commcell('My_commcell', commcell_login ,commcell_password)
client = commcell.clients.get('My_storage_array')
agent = client.agents.get('My_Agent')
backupset = agent.backupsets.get('My_Backupset')
backupset.subclients.add("backup_tmp", storage_policy="My_storage_policy")
subclient = backupset.subclients.get("backup_tmp")
subclient.network_share_auto_mount = True
subclient.content = ["My_storage_array:/My_Filesystem"]
subclient.enable_backup()
job_backup = subclient_fs.backup(backup_level='Full')
job_finished =job_backup.wait_for_completion()
paths_retore = "/My_storage_array/My_Filesystem"
job_restore = subclient_fs.restore_out_of_place(client="My_Client", paths=[paths_retore],destination_path="/My_storage_array")

the job is always pending and it detectes the number of files and folders to restore, the output is :

job_restore.pending_reason

'Failed to restore even a single file<br>Source: My_Client, Process: clRestore'

is there any command or anything that i’m missing ?

 

Thanks in advance for your help

 

Amine :D


8 replies

Userlevel 2
Badge +3

@loki  Code works fine. Could you please check?

Badge

@mhamel,

Can you please create a commvault support ticket? We may need the logs and CommServer to help you solve this.

 

Thanks

Badge +2

Hi @Sachin,

 

I opened a ticket to commvault support, no good answers was giving to me.

 

Thanks,

 

Amine

Badge

Hi @mhamel,

 

Sorry for the trouble you had faced earlier. If you could share the support ticket number we can start our discussions over there and work on this. 

 

Thanks

Badge +2

Hi @Sachin,

 

The ticket was opened by our subcontractor and was not handeled because the support said it does not process tickets regarding customer code, this is why i’m turning to the community to get some help.

 

Thanks

 

Amine

Userlevel 2
Badge +3

@mhamel Code works for us internally. We think the out of place restore you’re trying should’ve failed if you’ve tried it through Java GUI or Command Center. Could you please try that for this exact subclient: “backup_tmp” which is under client → My_storage_array → My_Backupset → backup_tmp and let us know? If it fails, then you may proceed with creating the support ticket.

Userlevel 4
Badge +11

Hi @Sachin,

 

The ticket was opened by our subcontractor and was not handeled because the support said it does not process tickets regarding customer code, this is why i’m turning to the community to get some help.

 

Thanks

 

Amine

@mhamel , can you send me the case number via a private message?  I’m not seeing it because it’s not under your name.

Badge

@mhamel As Mike has requested, have you shared the ticket number? We need this to escalate the case accordingly.

Thank you.

Alain

Reply