Solved

Vcenter intellisnap backup copy fail


Userlevel 1
Badge +4

Hello,

 

For some reason i don’t know yet, my vcenter’s intellisnap backup failed since several days.

 

Snap job passed, but backup copy never passed.

 

Now i have a problem with snaps size and dates, my storage team ask me what to do.

 

I would like to fully cancel this job but when trying to kill backup copy it still relaunch immediately, and want to clear the snaps history related to this job (vcenter, even if it does not seem to be problematic here, but storage too).

 

In other words, how can i really cancel an intellisnap composed job to clear all, please?

 

Thanks in advance.

 

Regards.

icon

Best answer by Mike Struening 7 September 2021, 21:33

View original

16 replies

Userlevel 5
Badge +12

Hi @f-red 

It’s likely that there is a BackupCopy schedule associated to the StoragePolicy/Plan. - This will be what is auto-starting the Backup Copies.

Do you see any errors on the BackupCopy Job? - i.e. Failed to mount?

 

*If* you want to mark the older (not-copied) Snapshots to not copy, you can do so by right click > “Do not backup copy”: Disabling a Job for Backup Copy (commvault.com)
Note: This can cause the snaps to be prune (Depending on Snap-Primary retention), therefore losing the ability to BackupCopy those Snaps.

 

Hope this can be of some help to you.

 

Best Regards,

Michael

Userlevel 1
Badge +4

Hello,

 

Thanks for your reply.

 

Do you see any errors on the BackupCopy Job? - i.e. Failed to mount?

==> Error message is: Error Code: [91:44] Description: Error getting datastore list for snap. Possible reason includes virtual machine spread across multiple datastores with multiple vendors. Source: bckpxy02-mar03, Process: vsbkp

 

But there is no spread in datastores.

 

I have currently some flap in network for a reason we are investigating, but only one on 40 subclients of this vcenter pseudo client is blocked.

 

So i just want to clear it up and relaunch.

 

*If* you want to mark the older (not-copied) Snapshots to not copy, you can do so by right click > “Do not backup copy”

==> After reading it seems like a permanent stop of backup copy, isn’t it?

 

This can cause the snaps to be prune (Depending on Snap-Primary retention), therefore losing the ability to BackupCopy those Snaps.

==> Yes, i would to prune this snaps too, but only those i want = on specific jobs, so not for every new snaps

Userlevel 2
Badge +3

can you unpick those jobs if you dont want to backup copy?

Userlevel 1
Badge +4

@asancheti I want to keep sublient, fix the problem if possible by cancelling blocked snaps / copy jobs, and let it continue backup

Userlevel 7
Badge +21

@f-red , that’s what @asancheti is referring to.  you can view the jobs on the backup copy and right-click the problematic jobs and mark them to not be copied:

https://documentation.commvault.com/11.23/expert/11750_configuring_backup_copy_operation_for_specific_job.html

Userlevel 1
Badge +4

I haven’t nothing in view/jobs for that client, on the storage policy.

My problem is that on a particular vmware subclient from 18, with no apparent reason, intellisnap backup does not work well anymore: on 38 vms, 23 are skipped and doesn’t backup with the following error message:

 

Error Code: [91:44] Description: Error getting datastore list for snap. Possible reason includes virtual machine spread across multiple datastores with multiple vendors. Source: bckpxy02-mar03, Process: vsbkp

 

No clear information in online documentation.

 

I’ve checked every vm to be sure no one is in a spread state.

 

Snap backup works

But backup copy no, for 23 vms, i don’t find any anomaly or specificity on them: not a question of proxy / host / volume / dscluster / media agent

 

I have completely emptied “list snapshots” list from right click on the subclient in problem state.

As snaps were stil not deleted form storage array, i’ve cleared all snapshots on the storage array.

 

I’ve relaunched job: same thing: snap ok but not backup copy.

Userlevel 7
Badge +21

@f-red thanks for clarifying for me!

Based on your details and the error, I would suggest creating a support incident so we can get someone to remote in and address your issue.

Please share the incident number with me so I can follow up accordingly.

thanks!

Userlevel 1
Badge +4

Already open for some days: #210609-529

I’ve discovered this community website very recently so i tried my luck on it, but the ticket was already opened.

 

Thanks to all of you, ‘hope we’ll find the issue very soon

 

Regards.

Userlevel 7
Badge +21

This is definitely a good place to come for help.  It’s extremely rare that we can’t find a solution without getting an incident created, not to mention all the cool articles we post here (with more to come)!

I’ll track the case and its progress, thanks :sunglasses:

Userlevel 7
Badge +21

Hey @f-red !  Hope all is well!

I was following up on your incident and see that the engineer is having trouble reaching you.  Let me know if I can help get you connected in any way.

Thanks!

Userlevel 7
Badge +21

Hi @f-red , following up to see if you were able to resolve your issue.  The incident has been archived due to the engineer having trouble contacting you.

Thanks!

Userlevel 7
Badge +21

Hey @f-red , reaching out one more time.  I see the case is closed due to support’s not being able to reach you.

Was this issue resolved on your end?  Can you share the fix?

Thanks!

Userlevel 4
Badge +11

We’d like to know what was the root cause, so @f-red can you get back to us ? :wink:

Userlevel 7
Badge +21

Updating that the case was archived due to no reply.  @f-red , were you able to get this working?

Userlevel 7
Badge +21

Hi @f-red , wanted to follow up one more time before closing off this thread.

I see the case archived due to no reply and is now closed.

Have you had a chance to revisit this issue?

Userlevel 7
Badge +21

Unfortunately, we have no answer and the incident is archived.  I’m marking this as the best answer in hopes that @f-red or another community member responds with the error again.

Reply