Solved

Virtualize Me Hyper-V Problem


Userlevel 3
Badge +8
  • Commvault Certified Expert
  • 25 replies

Hi!

We are in the middle of PoC with potential new customer and we ran into a problem with P2V to Hyper-V VM.

Error message:

Error Code: [19:1616]

Description: Virtual Machine Management job has failed because Refresh is not done for Virtualization client :[HYV-CL.company.com]. Please do refresh operation for this virtualization client.

Source: CV, Process: VMManagement

VMManagement.log:

10136 3888  08/31 11:20:46 ### Init() - Initializing job control [token=,cn=CV], serverName [CV.company.com], ControlFlag [1], Job Id [671]

10136 3888  08/31 11:20:47 ### DBBase-SQL() - dbmethods.cpp:1431, DB Layer will use [Exec] access by default. Use SetAdminAccess API for on demand Admin access.

10136 3888  08/31 11:20:47 ### Cvcl::init() - CVCL: Running in FIPS Mode

10136 3888  08/31 11:20:47 ### DetectNativeClient() - Found reg key [SOFTWARE\Microsoft\Microsoft SQL Server\SQLNCLI11]. Using driver [SQL Server Native Client 11.0].

10136 3888  08/31 11:20:49 ### CVJobCtrlLog::registerProcess(): successfully created file [C:\Program Files\Commvault\ContentStore\Base\JobControl\10.136]

10136 3888  08/31 11:20:49 671 #############################

10136 3888  08/31 11:20:49 671 # VM Management Job Started #

10136 3888  08/31 11:20:49 671 #############################

10136 3888  08/31 11:20:49 671 TaskInterfaceDB::getOptions() - Loading default options into memory

10136 3888  08/31 11:20:49 671 VmAuxOps::getClientIdAndInstanceIdFromClientName() - Failed to fetch virtualization client id from application table for the client name [HYV-CL.company.com], error[64]

10136 3888  08/31 11:20:49 671 VmAuxOps::fetchVCenterCredentials() - Trying for datacenter refresh for this client as it's a VirtualizeMe job.

10136 3888  08/31 11:20:49 671 VmAuxOps::fetchVCenterCredentials() - Failed to fetch instance Id from Virtualization Client [HYV-CL.company.com], error[64]

10136 3888  08/31 11:20:49 671 fetchVCenterCredentials failed. Error [64]

10136 3888  08/31 11:20:49 671 Updating credentials in VM Request failed

10136 3888  08/31 11:20:49 671 ###############################################

10136 3888  08/31 11:20:49 671 # VM Mananagement - Provision VM Phase Failed #

10136 3888  08/31 11:20:49 671 ###############################################

10136 3888  08/31 11:20:49 671 COMPLETE CALLED (PHASE Status::FAIL), Job ID = 671

10136 2e68  08/31 11:20:49 671 CVJobCtrlLog::unregisterProcess(): successfully removed file [C:\Program Files\Commvault\ContentStore\Base\JobControl\10.136]

Refreshing Hyper-V Datacenter won’t help.

I am not much of a Hyper-V guy, so I am kindly asking you guys for help. Any idea?

Thanks!

icon

Best answer by euMike 14 September 2021, 12:16

@Mike Struening , after re-reading your last message we managed to solve the issue. It was a bit different scenario but it helped us to understand what name was expected during the process.

Our case was like this:

  • client name: <short name>
  • display name: <short name>
  • host name: <short name>

When starting the Virtualize Me, the Hyper-V Instance was populated with fqdn(!) name.

In the end we changed the names from <short name> to fqdn. It not ideal but it works. Good enough for PoC.

Thank you for your help!

View original

13 replies

Userlevel 7
Badge +19

I found an internal article we have for this error and have the solution below.

Can you confirm if this applies to the client in question?

Dev has reproduced this in the lab but the fix will take time. CMR 302781 created.

In the mean time the customer can change the display name to match the client name as a workaround.

If it does, I can add your name to the CMR form for updates.

Userlevel 3
Badge +8

Hi Mike!

Which display name do you have in mind? DN of destination Hyper-V cluster or restored VM?

We will try this first thing tomorrow morning.

Thank you!

Userlevel 7
Badge +19

This client (which I assume is yourHyperV cluster):

HYV-CL.company.com

Keep me posted!

Userlevel 3
Badge +8

Hi Mike!

I was told that display and client name already match.

Since we have had quite a few problems so far, I suspect that there could be something wrong with their environment/setup. I will try to reproduce the problem in our lab and let’s see what happens.

Thank you anyway!

Userlevel 7
Badge +15

Have you run refresh datacenters on the VM client?

Userlevel 3
Badge +8

@Damian Andre yes, multiple times. It didn’t help.

Userlevel 7
Badge +19

Keep us posted.  If it still gives you trouble, opening an incident is best at this point.

Userlevel 7
Badge +19

Hi @euMike , following up to see how this issue is looking.  Did you get it resolved?  Or open an incident?

Thanks!

 

Userlevel 3
Badge +8

Hi @Mike Struening , I was not able to reproduce the issue in our lab.

Due to trial license opening an incident is not an option.

Userlevel 7
Badge +19

@euMike , to confirm, is this a trial as in a PoC, or as in ‘you downloaded the trial version of the software’?  The latter DOES get support.

I checked again to see if any new issues/solutions have come up, but this one was all I found (essentially the same solution, though better written):

Identified that Virtual Server Client Name is '<short name>' but Display Name is 'FQDN'. When starting Virtualize Me, in step 2, Hyper-V Instance drop-down is populated with Display Name. When the job is submitted, Commserve searched for Client Name matching the selected Display Name.

Userlevel 3
Badge +8

Hi Mike, the installation package was downloaded from store.commvault.com (Enterprise Kit). The CC ID (ffffffff) is not linked to any existing Maintenance Advantage account.

License Information:

  • License type: Pilot
  • Evaluation Days: 60

I could be wrong but I believe this one doesn’t get support, or does it?

We checked Client Name, Display Name, and Host Name - they all match.

Userlevel 3
Badge +8

@Mike Struening , after re-reading your last message we managed to solve the issue. It was a bit different scenario but it helped us to understand what name was expected during the process.

Our case was like this:

  • client name: <short name>
  • display name: <short name>
  • host name: <short name>

When starting the Virtualize Me, the Hyper-V Instance was populated with fqdn(!) name.

In the end we changed the names from <short name> to fqdn. It not ideal but it works. Good enough for PoC.

Thank you for your help!

Userlevel 7
Badge +19

Great news!  and to confirm, you are correct, no support for those.

This is the Trial version I was referring to:

https://www.commvault.com/trials

Reply