Solved

VPN Tunnel

  • 13 October 2021
  • 7 replies
  • 58 views

Userlevel 3
Badge +12

Hello Guys,

I need a help if is necessary create a Proxy to communicate to CommServ or not?

 

icon

Best answer by Fernando Souza 13 October 2021, 19:50

View original

7 replies

Userlevel 5
Badge +12

Hi @Fernando Souza ,

You can configure the Hyper-V Server as a “Proxy” / ”Gateway” to allow comms to the CS.


Using the Advanced Network Configuration Settings, select this option In the “Options” Page of the Network Route Configuration: 


Then on the CS you would configure an outgoing route to “SQL Server” via Gateway and select “HyperV” as the Gateway.

On the SQL Server you would configure an outgoing route to “CommServe” via Gateway and select “HyperV” as the Gateway.

 

Further details on this configuration can be found in the documentation here: https://documentation.commvault.com/11.24/expert/7270_network_gateway_in_perimeter_network.html

 

Best Regards,

Michael 

Userlevel 3
Badge +12

Hello @MichaelCapon 

Thanks, I'll make this configuration and then I'll let you know. 

Userlevel 7
Badge +15

@MichaelCapon has it!

 

Commvault is super flexible with networking. You can route data through any client, and even string multiple proxy clients together (although the configuration starts to get complex, it works!).

Userlevel 3
Badge +12

Hello @MichaelCapon and @Mike Struening and @Damian Andre 

i made this configuration for access the same proxy:

On the MA that is exposed to Commserv, i Activated the “Proxy/Gateway”

 

Doubts:
 

“Then on the CS you would configure an outgoing route to “SQL Server” via Gateway and select “HyperV” as the Gateway.

On the SQL Server you would configure an outgoing route to “CommServe” via Gateway and select “HyperV” as the Gateway.”

 

what is “Outgoing Route”? 
The information that i found:
 

I added the MS SQL Machine Agent

But i´m having problems trying to register the SQL client, i removed the agent and installed it again:

Something is failing.

 

 

Userlevel 7
Badge +15

This looks correct to me - couple more things.

The SQL client also needs the Hyper-V proxy listed in incoming connections, so both the proxy and the SQL client know how to communicate with each other.

If that doesn't work, try this:

On the properties of the SQL client, goto the advanced network settings and get to the summary tab - that will list out the text that should be in fwconfig.txt in the base directory on the client. Copy the text and paste it into fwconfig.txt on the SQL client just to make sure it has received the right network config. Once the client is already installed you can get into a chicken/egg scenario where the network does not push out. That's one way to seed it, assuming you have access to the SQL client.

 

Userlevel 3
Badge +12

Solved, the problem was about SQL authetication.

Reinstall the agent and Solved
Thanks all @Damian Andre @MichaelCapon @Mike Struening 

 

Userlevel 3
Badge +12

This looks correct to me - couple more things.

The SQL client also needs the Hyper-V proxy listed in incoming connections, so both the proxy and the SQL client know how to communicate with each other.

If that doesn't work, try this:

On the properties of the SQL client, goto the advanced network settings and get to the summary tab - that will list out the text that should be in fwconfig.txt in the base directory on the client. Copy the text and paste it into fwconfig.txt on the SQL client just to make sure it has received the right network config. Once the client is already installed you can get into a chicken/egg scenario where the network does not push out. That's one way to seed it, assuming you have access to the SQL client.

 

thanks

Reply