Drive allocation policy discrepancy

  • 12 July 2021
  • 5 replies

Userlevel 4
Badge +13

Hi all,

in Master Drive Pool Properties there is set Drive Allocation Policy to Use All Drives. In our case, we have 4 drives fully accessible. However, only 2 drives are in use. Is it possible that this settings is somehow and somewhere overriden? Is there way to figure out why are some of the drives idle? There is a lot of running jobs accros the multiple storage policies so it would be good to utilize all drives.



Best answer by drPhil 16 July 2021, 08:29

View original

5 replies

Userlevel 7
Badge +23

@drPhil , it looks like you are indeed limiting their usage via the 2 device streams setting.

Is that second screen from the Storage Policy properties?  Assuming so, that will define the maximum streams for the Primary Copy (and the Secondary, if not combined into a smaller amount).

Userlevel 2
Badge +3

Hello DrPhil,

Most likely, you will need to increase the number of drives that can be used by the master drive pool.
Adding a link to documentation. Please review and let me know if it helps.

Set the Maximum Number of Drives for each Drive Pool in a Master Drive Pool


Thank you,

Userlevel 4
Badge +13

Hi @Sandip Domadia, as I wrote, the Drive Allocation Policy is set to Use All Drives. However, only half of them are in use. Is it possible that this settings is somewhere overriden?



Or is there any relationship with Number of Drives in use and the Number of Device streams, that are set under associated storage policy? Or can the limitation be the number of licence libraries/drives within the Commcell?



Userlevel 4
Badge +13

Hi @Mike Struening, @Sandip Domadia . The solution was to decrease the multiplexing factor. Once the multiplexing factor was changed from 50/25 to 10, all 4 drives are in use now. Moreover, we have slightlyincreased the number of device streams.

Userlevel 7
Badge +23

That makes sense….you likely had enough for all of your jobs to run without spilling into drive 3 or 4.

Thanks for sharing!!!