Question

AppAware backups failing since update to 11.34.5

  • 4 March 2024
  • 6 replies
  • 126 views

Badge +3

Upgraded to Commvault version 11.34.5. 

 

We are running intellisnap backups and AppAware for SQL 

 

Since the update SQL AppAware backups do not work the default way for this version, App Consistent. 

 

The manifest.zip file that is sent to Commvault from vmware doesn’t contain the xml files needed, Writer.xml. 

 

Per Commvautl/VMware this failure is happening on the VM client OS side of things. 

 

Has any experienced this issue?

 

Thank you


6 replies

Badge +3

Hi Emmanuel, 

The setting is nEnableHypervisorAppConsistentBackup

This was placed on the Media agents/storage Hyperscale nodes. 

Name: nEnableHypervisorAppConsistentBackup

Category: Virtual Server

Type: Integer

Value: 0

Enable: Box checked

 

This reverted App Aware backups to work as they did before upgrading to 11.32 or above. You will need likely need to restart Commvault services on the media agent/node once applied. 

 

Thanks, 

Bryant

Badge

Hi,

We are experiencing the same problems with SQL and AppAware on some clients since the upgrade to version 11.32.

The VMware tools update suggested by the support did not fix all the problems.

Can you tell us more about this parameter to apply on the media agent?

Thank you,

Badge +3

Hi Scott

 

Thanks for the information. 

I did run streaming backups to get us by. App-Aware are working now, but not in the manner used starting with 11.32, which uses the SQL VSS writer to create an app consistent backup. 

Commvault provided a setting to be placed on the media agent to revert back to appaware backups prior to 11.32 versions. 

Thank you

Badge +3

Hello Sebastien, 

 

The error message was. Error Code: [76:262] Description: Failed to replicate snapshots for subclient [default] using DDR. Source: ‘SQL Server name’, Process: SQLBackup

 

The DB portion of the backup was failing. the VSA completed with errors bacause it couldn’t complete the app aware portion for the backup. 

 

Thank you

Userlevel 6
Badge +14

@Cbcurry1 

You might already know but as you work through this issue you can turn off appaware and run regular streaming SQL backups until this issue is resolved. You can turn it off on the VSA subclient properties.

Also does this happen on multiple servers or is it just one vm that is having the issue?

 

Userlevel 6
Badge +14

Hi @Cbcurry1 ,

Can you confirm which backup is failing, is it the VMware Backup or the SQL?

Also, can you confirm the error message?

Best Regards,

Sebastien

Reply