Question

deleteClientAuthorization email approval configuration

  • 19 October 2023
  • 7 replies
  • 194 views

Badge +1

We recently moved from on Prem email to cloud, and with the move the deleteClientAuthorization workflow stopped working. I know we have to reconfigure the Email Approval settings (image below) but not really sure what server to define there. Tried outlook.office365.com and made sure the account we are using has IMAP enabled but still doesn’t work.

 

 

Anyone here has this configuration on their environment? Any other tweak we need to change on the user account/user mailbox for it to be able to login using IMAP?

Appreciate any idea that anyone thinks be helpful in this scenario.

 

Thanks in advance.


7 replies

Userlevel 1
Badge +1

Good day @bpin,

I apologize for the delay in responding to your query. We are currently in the process of arranging an engineering review for your question. Please rest assured that we are working diligently to provide you with a detailed response as soon as possible.

Thank you for your patience and understanding.

Userlevel 1
Badge +4

Hi @bpin ,

What do you mean by the workflow stopped working?

Is it not asking for authorization anymore?

Thanks,

Yeshwanth

Badge +1

Hello @Yeshwanth ,

Thank you for your response.

When I said “it stopped working”, I meant Commvault is not able to get the authorization response anymore. The part of the workflow that sends email asking for authorization to “accept” or “deny” still works and we are still able to respond to the email, and can confirm that the response is being accepted by the mailbox, but the part where Commvault reads the response does seem to be working anymore. I know there is a configuration I might be missing here, just not really sure what/where to configure it.

Userlevel 1
Badge +4

Hi @bpin ,

Before moving from prem email to cloud. Did you have any configuration or setting in place? 

Thanks,

Yeshwanth

Badge +1

@Yeshwanth , From the screenshot I provided, we used to point to the local server, but now being on the cloud that’s one thing I’m not sure to point to, I set it to outlook.office365.com but that doesn’t seem to work and also I made sure that the account I am using has IMAP enabled since I believe Commvault uses IMAP.

Userlevel 1
Badge +4

 

  • Email Server: The name of the email server.

    For example, enter smtp.companymailserver.com.

  • Mailbox: The email address of the mailbox that should receive the reply emails sent by the users.

  • Password: The password for the email account in the Mailbox.

  • Folder: The name of the email folder that is used to store the emails sent by the users.

    For example, enter Inbox.


    Can you try this please?

Badge +1

Hi @Yeshwanth , thanks for the input but I’ve already tried that, following this doc from commvault https://documentation.commvault.com/2023e/essential/131207_enabling_email_responses_to_interact_with_workflows.html

Just not really sure what the email server name would be being in M365, tried outlook.office365.com but commvault still doesn’t seem to be able to communicate and read/get access to the email response.

Reply