Solved

commvault.service systemd timeout

  • 30 August 2021
  • 2 replies
  • 1231 views

Badge +2

the Commvault service on Linux systems is configured with a timeout of 900 seconds.

This means, if the service is not properly starting or stopping, systemd will wait 15 minutes until it will fail.

 

$ grep Timeout /etc/systemd/system/commvault.service

TimeoutSec=900

 

We faced this problem today when rebooting a server and had to wait 15 minutes just for it to properly shut down because of this.

 

Is there any way of configuring it to a lower value by any additional settings on the commcell console ?

I’ve already try to add an additional setting called : nJobProcessRegistrationTimeout ( with a value of 90 ) but it doesn’t seem to help. 

icon

Best answer by Praveen Bandaru 30 August 2021, 17:00

View original

2 replies

Badge +2

Hi Lionel,

 

It seems like the CVD process on the Linux server was extremely busy at that particular time causing the Services to not go down in timely fashion. Were there any Commvault jobs running on that server at that time?

 

We do allow modifying the TimeoutSec value by editing the file /etc/systemd/system/commvault.service.Instance001 and changing the TimeoutSec to a lower value in seconds.

 

Once the change is made, we need to run the following commands for the change to take effect.

 

1). systemctl daemon-reload

2). commvault restart

 

Userlevel 2
Badge +12

Hey Praveen,

 

thanks for info. Is there any hint in the documentation ? 

 

Is 900 actually the default value ?

Reply