Solved

Remove mount options for InteliSnap

  • 20 January 2023
  • 4 replies
  • 65 views

Userlevel 1
Badge +7

Hello,

Trying to mount InteliSnap snapshot from Ubuntu 18 on Ubuntu 20. Filesystem was mounted with nobarrier option, obsolete in Ubuntu 20:

 

1899337 26ca0b 01/20 14:07:29 ####### DoMount() - DoMount :** System returned  =  32, stderr = mount: /mnt/ble/volume_784_1674219622: wrong fs type, bad option, bad superblock on /dev/mapper/pgdata--oas--vg_copy_001-pgdata--oas--lv, missing codepage or he
lper program, or other error.
  **, running fsck on the device and retrying mount

 

Any ninja option to fix that? (other than use same version on target system😎 ). 

 

In MA.log there is : 

1899337 26ca0b 01/20 14:07:28 ####### GetMountOptionsFilter(10504) - default common skip options [cio] (1)

 

is there a way to add other parameter to “skip” list? 

 

 

 

 

 

 

 

 

 

 

icon

Best answer by Orazan 23 January 2023, 13:52

View original

4 replies

Userlevel 1
Badge +7

I did downgrade, but good to know there is a workaround. 

Thanks.

 

Userlevel 6
Badge +15

Good morning.  Can you please verify if this is a file system snap backup or is this a database backup that you are attempting to mount?

 

Userlevel 1
Badge +7

Hello. It’s database psql backup. 

Userlevel 6
Badge +15

You would either have to mount to a Linux box which does not have the nobarrier parameter deprecated or your other option is to open a support case.  There possibly is a workaround that Development can provide to assist.

Reply