Question

Upgrade from 11.24 to 11.28, depreciated clients

  • 29 March 2023
  • 7 replies
  • 658 views

Badge +7

Hi,

I have 11.24 release installed and plan upgrade to 11.28 (in this release Windows Server 2012-2012 R2 depreciated). Could you say please:
1) What will happen with agents which are installed on depreciated OS  after Commserve and media agents will be updated to 11.28, will it continue to work normally?
2) What will happen with support if I have Commserve version 11.28 but clients run 11.24 (which also is still under support and supports older OS)? Does this combination will have full support?

Thanks!

Br,

Andrejs


7 replies

Userlevel 6
Badge +14

@AndresL ,

You can yes, that does not mean you are going to have issues.

Also, we will always try to support and fix potential issues.

Now the other more critical issue you may have is that Windows 2012R2 is going to be EOL:

https://learn.microsoft.com/nl-nl/lifecycle/products/windows-server-2012-r2

Best Regards,

Sebastien

Badge +7

@Sebastien Merluzzi,

Ok, thanks, its clear.

Please answer one more question. If for example I need to stay on on some client on 2012 R2 OS, longer than FR24 will be supported by Commvault. What you would suggest in this case, to leave this client on latest possible maintenance release of FR24 or to try install newer Feature Release?

Br,
Andrejs

Userlevel 6
Badge +14

@AndresL 

That’s fine, MRs can be lower/higher.

Now what you need to check for example is if we have fixed an issue in 28.44, it is to make sure that the fix is also in 24.94. If not, then you would need to install 24.98.

This is the only thing I have found:

https://documentation.commvault.com/2022e/expert/2617_platform_releases.html

Best Regards,

Sebastien

Badge +7

@AndresL ,

You can have Commserve and Media Agents on FR28 and Clients on FR24, that’s not a problem.

Best Regards,

Sebastien

@Sebastien Merluzzi ,

Yes I understood this.

Now I speak about Maintenance release compatibility between FR28 and FR24. For example I have Commserve and Media agent on 11.28.44 (Jan 10, 2023) , but client on 11.24.94 (Mar 07, 2023) .
If we compare numbers then client has lower version, but really you see that release is newer. What is the rule for compatibility in such case? Do I need to follow date of release to be sure that it is compatible?  Maybe you know KB where it is documented?

Thanks!

Br,

Andrejs

Userlevel 6
Badge +14

@AndresL ,

You can have Commserve and Media Agents on FR28 and Clients on FR24, that’s not a problem.

Best Regards,

Sebastien

Badge +7

Hi @AndresL ,

You need to keep these Clients on FR24 and they will be supported until the end of its support.

Best Regards,

Sebastien

Hi @Sebastien Merluzzi,

Thank you for reply!

Normally, when you have all clients on same FR then clients should have same or lower version than Media agent or Commserve. 
Could you please suggest how to maintain version compatibility in case if some agents are on FR24 but rest system on FR28. I mean maintenance release compatibility between FR28 and FR24.
 

Userlevel 6
Badge +14

Hi @AndresL ,

You need to keep these Clients on FR24 and they will be supported until the end of its support.

Best Regards,

Sebastien

Reply