Global Storage Copy Policy - to Tape - Error when changing retention

  • 28 February 2022
  • 8 replies

Userlevel 4
Badge +12



Has anyone seen this error when changing retention on a Tape Global Copy policy


The policy was initially a ‘basic’ policy using days


The change was to add Extended retention


Best answer by Mike Struening RETIRED 25 March 2022, 21:45

View original

If you have a question or comment, please create a topic

8 replies

Userlevel 7
Badge +23

@YYZ , I searched for that phrase and it doesn't show up at all in our database. If you check EvMgrS.log for the time this popped up, do you see anything?  anything in the Event Viewer?

More than likely, you should create a support case.  It’s likely some sort of database conflict.

Throwing in one thing, are you trying to add Extended Retention that’s lower than the basic?

ps nice avatar image, of course!


Userlevel 4
Badge +12

Hi Mike

I checked event viewer - filtered on code 175.

Nothing was there. - ie no error appears at all


Once the error occurred, I checked / turned off / tried various options in the settings, but same error


Basic should be less than extended

Different Grace Periods

Make the modification under Storage Polices - but also try getting to the same settings via Storage Pools

And then try a few ‘random’ options to see if the error keeps appearing


I’ll get a ticket raised with Support at get the CommServe DB uploaded.


Thanks for taking a look and for the comment :-)



Userlevel 7
Badge +23

Of course, I’m definitely invested in this one :nerd:

Can you share the case number here so I can follow its progress?

Userlevel 4
Badge +12

Hi Mike

Case Number is 220302-438

Looks like a ‘duplicate key’ issue within the CommServe - Support are staging the DB




Userlevel 7
Badge +23

Appreciate the update!  I’ll keep an eye out.

Userlevel 7
Badge +23

Sharing the case solution:

Finding Details:

Receiving an error when attempting to add extended retention on a Global secondary copy


Found that we would only get the error when attempting to add Monthly Full extended retention.
- Adding for any other frequency was successful.

Looking at all the dependent copies to this global secondary copy we found that there were 2 copies that already had monthly full extended retention set on them.
- It appears at some time in the past these 2 copies had the extended retention set, then started to inherit the global secondary copy retention settings.

As the extended retention was entered, but not honored (as inheriting the global copy retention), it still had a record in the database of these settings.
- When you were trying to add the monthly retention on the global copy it was updating the same database table resulting in a duplicate record, hence throwing the error.

To get around this, for the two copies that had extended retention already set, we simply clicked the option in the copy properties to "Override the retention settings for this copy"
- Now when trying to add the Monthly Full extended retention on the global copy, it was not trying to add a duplicate record since the override option was enabled.

Userlevel 4
Badge +12

This was an incredible piece of Detective work from the Support Engineer.

Not sure if you have an annual Great Detective award at CommVault, but I’ll nominate this one if I may for a Columbo, Kojak or Hawaii Five-O award!!




Userlevel 7
Badge +23

I’ll pass the praise along!!