Question

VAIO Setup

  • 7 March 2023
  • 4 replies
  • 318 views

Badge +1

Hi everyone. I am currently testing and documenting the setup of the continuous replication (VAIO) in a test environment. When installing the VAIO filters, I keep getting, “The operation is not allowed in the current state.” I used the built-in administrator too. I can’t open a support ticket as it is not a licensed CS. Just wondering if anyone else has seen this?

4300  80    03/07 15:48:59 30  Failed to install IO filter http://VAIO-CS:80/webconsole/downloads/VAIO/cvtblrh/7.0/1.23.4/offline-bundle.zip on cluster WL-dHCI, Error:[The operation is not allowed in the current state.]
4300  80    03/07 15:48:59 30  CBlrDrvInstall::Install(480) - Failed to install Head IO filter. Host:[vcenter_name_removed] Err:[0xFFFFFFFF:{BlrVSOperation::InstallIOFilter(700)/Int.-1.0xFFFFFFFF-Couldn't install Head IO filter}]
 

Thanks,

John


4 replies

Userlevel 7
Badge +23

Hey @jgenteman 

The most likely reason is that the host is not in maintenance mode or cant enter maintenance mode. Try put it into maintenance mode manually and retry - resolving any issues preventing the host from being in maintenance mode. If not, another very common issue is that the ESXi host cannot resolve the hostname of where the file is hosted - i.e VAIO-CS. SSH to the ESXi host and try a ping to see if it resolves.

VMware has a KB on troubleshooting name resolution but the quick is a quick hosts file entry to allow it to resolve your CommServe/webserver

 

https://kb.vmware.com/s/article/1003735

Badge +1

Hi Damian,

 

Thanks for responding. I also tried to put the ESX host into maintenance mode manually and got the same error. Ill check on the ESX host and make sure it can resolve the hostname. Standby on that one.

 

Thanks,

John

Badge +1

Hey @Damian Andre,

 

ESX hosts can ping the CS and the filter install failed again.

Putting the host into maintenance mode also did not work.  Still getting the operation is not allowed error on the vCenter recent tasks.

 

[root@WL-ESXI:~] ping vaio-cs
PING vaio-cs (10.0.47.12): 56 data bytes
64 bytes from 10.0.47.12: icmp_seq=0 ttl=128 time=0.297 ms
64 bytes from 10.0.47.12: icmp_seq=1 ttl=128 time=0.195 ms
 

Userlevel 1
Badge +6

Try to check certificate on the vCenter, maybe the EAM is expired.

for store in $(/usr/lib/vmware-vmafd/bin/vecs-cli store list | grep -v TRUSTED_ROOT_CRLS); do echo "[*] Store :" $store; /usr/lib/vmware-vmafd/bin/vecs-cli entry list --store $store --text | grep -ie "Alias" -ie "Not After";done;

Reply