Question

Global Secondary Copy to Tape (Storage Pools) and Device Streams

  • 23 November 2022
  • 6 replies
  • 536 views

Userlevel 4
Badge +12

With a Tape Library of 8 Drives, I wanted to force the Tape Aux Copy  to a single Drive

        This will be for only one Storage Policy XYZ (out of 30 or so SP’s)

        and for only  a single Storage Policy Copy ABC (within SP XYZ)

 

There are multiple Tape Storage Pools set up   eg POOL-N, POOL-O, POOL-P,   … POOL-X

 

Storage Policy Copy ABC used POOL-X

I had hoped that setting the Device streams to 1, but this still results in multiple drives being used

 

 

If I run a manual AUX Copy, for Storage Policy XYZ, for copy ABC and set the number of readers to 1, that works fine - as I’ve limited the stream to 1 ‘at the source’’, meaning there can never be more than 1 stream at the target - and therefore 1 tape used

 

I could create new AUX Schedules an change the AUX Job options for just that schedule and apply that schedule to to just the AUX Copies where I want to use a single Drive

But that will be messy

 

I could also limit the stream to 1 (combine stream)  on the disk source copy that then feeds the Tape Global Secondary Copy policy...That will work

 

 

As I’m sure Ive done this an easier way some years back (likely when a Tape library could be configured as a direct target and not via a Storage Pool??

 

Is there another way - Is there something I’m missing

 

 

 

 


6 replies

Userlevel 4
Badge +12

I should add - this is FR11.28

 

and this note from BOL highlights the device streams (I assume, which is dangerous) in the Storage Pool Properties - set to 1, should limit the writes to 1 tape 

Userlevel 3
Badge +8

I want to say this is not expected behavior

Userlevel 4
Badge +12

I want to say this is not expected behavior

I had support take a look, and its not the behaviour they expected

Logs have been uploaded - I’ll let you know.

 

Userlevel 2
Badge +11

Any response for this?

Userlevel 4
Badge +12

Hi Pedro

 

There is - Sorry - I never updated the forum:

 

  1. Make sure you’re on the latest Maintenance Release
  2. But here’s the real catch
    1. When a Stream is set to 1, I was expecting ONLY a single tape drive to be used.
    2. BUT - CommVault could possible take 24 Hours (Maybe more) before that setting was updated across the system !!!
    3. The first “trick” is to change your Stream down to 1
      1. then restart the commvault services on the media agent that uses the Tape Library - That should result in the the Stream being = 1
    4. If this does not work, then go back, and change the STREAM from 1 - back to (for example) 2 - and close the ‘commvault configuration’ panel
      1. Then open it up again, and change from 2 to 1 

I hope this helps someone

 

Badge +3

sorry us maybe is not 100% related to You problem but we have very very similar to Your but even in easier situation as we have not using Global Secondary Policy but just Normal Storage policy.

 

Now are similar thing:

  • also have 11.28
  • our SP also save data into Tape Library. Saves data directly mean primary copy of SP is saving directly to tape 
  • normally our SP copy have set to use 2 data streams   and 99% times is using correctly 2 tapes 
  • sometimes CV forget what is set on SP copy level and when jobs starting using (usually) 4 tapes (device stream) 
  • solution from CV was like from 1980 and similar to Your method in Your example “go to SP copy level and change streams to 3 & save ..then go again to SP copy level and change to “wanted” 2 device stream”

Then You just start jobs and all again works correctly :) ….

Dear CV it was on March ...now We have July ...few monthly MR meantime installed ...and what and still sometimes CV do what want to do ...not keeping what is set on SP copy level ….really i want to see that part of CV code as it must be in style “the programmer cried as he coded”    

Reply