Oracle RMAN backups - Connection with ClOraAgent failed

  • 8 February 2021
  • 8 replies

Badge +1

We have problem with backing up Oracle database via RMAN on Linux server. 
CommVault version is 11.20.9. When we kick off backup from RMAN it fails with these errors:

RMAN error:

RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03009: failure of backup command on ch1 channel at 02/03/2021 20:55:06
ORA-19506: failed to create sequential file, name="1024672_PPRFLPU_7bvm9l7h_235_1_1", parms=""
ORA-27028: skgfqcre: sbtbackup returned error
ORA-19511: non RMAN, but media manager or vendor specific failure, error text:
   CreateOraObject20: Job[1024672] thread[29473]: Connection with ClOraAgent failed(180 secs) for channel=1.


29473 7321 02/03 20:54:59 1024672 ::ConnectWithClOraAgent() - Attach_RemoteService to connect to ClOraClient failed with error [0x80
070306:{CCvNetwork::Attach_RemoteService(1691)} + {CCvNetwork::Attach_RemoteService(1654)} + {CCvNetwork::LookupRegisteredPorts(4697
)} + {CCvNetwork::LookupRegisteredPorts_Common(4822)} + {CCvNetwork::LookupRegisteredPorts_Common(4789)} + {CCvNetwork::LookupRegist
eredPorts_Local(4456)} + {CSessionConnectionSocket::LookupPort(1093)/W32.774.(One or more errors occurred while processing the reque
st. (ERROR_ERRORS_ENCOUNTERED.774))- No port looked up for service OraSbtSrvcData1024672_1}] for channel=1
There seems to be a Port configuration issue on servername server.

Fireweall is off on Linux server. When i run backup from CommCell for given subclient it finishes successfully. 
We also have file agent installed to back up Linux OS and its also working OK.

Tried looking at this error but did not find much: "No port looked up for service OraSbtSrvcData".

Anyone had similar problem maybe? 


Best answer by Gowri Shankar 8 February 2021, 22:16

View original

8 replies

Userlevel 4
Badge +13

Understand that backups initiated from RMAN interface fails, however GUI backups are successful. 


Check the following -


RMAN parameters in the backup script 

BOL Link →


allocate channel ch1 type 'sbt_tape' PARMS="SBT_LIBRARY=/opt/commvault/Base64/libobk.a(shr.o), BLKSIZE=1048576 ENV=(CvClientName=Myclient, CvInstanceName=Instance001)" TRACE 0;

Replace Myclient with the CvClient name 

Replace Instance001 if the instance name is different


How to find the Client name and instance name

Login as root and run the command “commvault status”

sample out put

 commvault status --------------------------------- Instance001 --------------------------------- [ General ]  Version = 11(BUILD80) SP16 (2046897)  HPK1(16Jun)  CommServe =   Home Directory = /opt/commvault/Base  1204/CVGxOrIDA  = Oracle iDataAgent  1301/CVGxMA  = MediaAgent

[ Physical Machine/Cluster Groups ]  Display Name = myclient   - Client Hostname =   - Job Results Directory = /opt/commvault/iDataAgent/jobResults   - Index Cache Directory = /opt/commvault/MediaAgent/IndexCache



Make sure commvault agent is installed with appropriate group, to check this login as root and run the command “id oracle” 


# id oracle uid=501(oracle) gid=503(oinstall) groups=503(oinstall),501(dba),502(oper),504(backup)

verify ls -l /opt/commvault

If oracle group is not provide then run  the following command as root


cvpkgchg -g oinstall -p 775


If the issue still persists, paste the entire RMAN log 

Badge +1

Yes, backup initiated from RMAN fails, GUI works. Thank you for help! Will check it today.

Badge +1

OK, we still had some problems running backups after listed checks but what solved it is: 

Since backups were working from CommCell, we copied RMAN scripts from manual run and created cron job based on it. After that full ,archive log and incremental worked fine.

Thanks for all help!

Userlevel 7
Badge +23

Hey @neuwiesener , I’m going to split this into a new thread to track your answer.


Userlevel 7
Badge +23

Moved new question to its own thread:


Badge +1

Go to home directory and run ./cvpkgchg and allow permission to other users for read/write and execute.

It will fix automatically.


Getting error: RMAN returned WARNING during backup operation [RMAN-06820: warning: failed to archive current log at primary database]. Please check RMAN logs for details and take corrective action. Source: drporstgdb01, Process: ClOraAgent


No error such. We already disabled switch current log then why still it is going to through it.