HDS integration with CommVault Intellisnap and VMware

  • 25 June 2021
  • 3 replies

Userlevel 1
Badge +4

If you are in de rare occasion that you implement Hitachi SAN storage in combination with a vSphere Cluster. And you want to integrate this with CommVault Intellisnap and Hitachi Raidmanager/commanddevice.  You might get into troubles when you name your Datastore with a COLON ": “ . If you identify your datastore with the LDEV ID like “Datastore 04:00” CommVault does not understand this and interpret this wrong in the code.

The Job fails and cannot find the CommandDevice in the MetaResource.

xxxxx xxxxx xx/xx 11:26:22 ##### GetPageInfoForExtent() - Host: [server-vmesx01.vmware.local] LunUuid: [DATASTORE 04:00:020001000060060e8012bb80005040bb80000003004f PageNameSpace: [GENERIC_VPD]

3 replies

Userlevel 6
Badge +14

Hi @HenkR ,

This is noted in the documentation generally for VMware:

Ensure that names of virtual machines and datastores do not contain the following special characters:

+ & @ % = # % * $ # ! \ / : * ? " < > | ; '

Ref: Creating a Virtualization Client for the VMware vCenter (commvault.com)


Backup or restore can fail if the name of the datastore, cluster, or virtual machine contains any of the following characters:

+ & @ % = # % * $ # ! \ / : * ? " < > | ; '

Ref: Backups for VMware (commvault.com)

Best Regards,


Userlevel 1
Badge +4

Interesting, haven't seen this requirements before or did/was never encountered/aware of this. Strange that seems to be easily prohibit from within VMware/CommVault code/interface to warn you about this. But may be that is to easily thought and is not prohibit by CommVault anyway.

Thnx for referring to this article.

Userlevel 1
Badge +4

After testing without the : character it worked. Unfortunately we used now a underscore as a separator in the Datastore and that did not worked either. Snapshot on storage can not be made with both character in the name of the Datastore (VMware)

The VSBKP and CVMA log reporting the same issue as with the : character before.
A hardware snapshot creation failed.

Even when you change the object in the subclient it will not work, it is recommendable to create a new subclient. Only then a hardware snapshot can be create as it should be.

Although this characters is not mentioned in the related article.