Solved

Aux copy jobs are stuck on 99%

  • 16 June 2021
  • 9 replies
  • 623 views

Userlevel 4
Badge +13

Hi there,

 

have you ever seen in the Job Controller view, that there are some Aux copy jobs on 99% (progress bar) for a couple of days? Moreover, Estimated Completion Time says Not Applicable. However, Application size and Total Data Process number is slightly increasing during the time. And of course, aux copy jobs are in therunning state.

 

My assumption is and it looks like that there are still some jobs needed to be copied from the primary to the secondary policy copy. Is it possible? And is it worth to wait for the job completion or better to kill the job.

 

 

icon

Best answer by Mike Struening RETIRED 16 June 2021, 16:20

View original

9 replies

Userlevel 4
Badge +11

Not sure how i missed this question, the job does not hit 100% - 99% then can run for addtional days

Userlevel 7
Badge +23

@Matthew M. Magbee , hmmmm…..is the job sitting at 100% for a while and eventually finishes, or does the aux just take a while to run?

How long are we talking start to finish and how much data?

Userlevel 4
Badge +11

Im actually running it that way now. while it eventually ends without issue- its delayed quite a bit. 

Userlevel 7
Badge +23

@Matthew M. Magbee , I believe this is what you are looking for:

https://documentation.commvault.com/2022e/expert/11545_auxiliary_copy_faq.html#how-do-i-prevent-data-of-ongoing-backup-jobs-from-being-copied

How do I prevent data of ongoing backup jobs from being copied?

For auxiliary copy operation with Use Scalable Resource Allocation option not selected, all eligible data even from the backups that have finished after the auxiliary copy operation has started are selected to be copied. However, you can prevent this data of ongoing backup jobs from being copied by adding the AUXCOPY_NOT_PICK_NEW_BACKUPS additional setting.

Property

Value

Name

AUXCOPY_NOT_PICK_NEW_BACKUPS

Category

CommServer

Type

Integer

Value

Select one of the following values:

  • 1 - prevents data of ongoing backup jobs from being copied

  • 0 - all ongoing backup jobs are also copied

Userlevel 4
Badge +13

Hi @Matthew M. Magbee , as far as I remember, we let the backup jobs running and after some time, they were finished. What to do from happenig this… In our case we had a lot of backup jobs to do/copy, because there were performance issues on the switch/storage array.

Userlevel 4
Badge +11

I am dealing with this now- at what point will it stop? Hate to think of jobs queued because this is still running. What changes have you both made to keep this from happening?

 

Userlevel 7
Badge +23

Great, thanks for the confirmation!

Userlevel 4
Badge +13

@drPhil , good question!

This is generally due to new source copy jobs that completed after the Aux Copy started (and calculated its run/completion time/percentage).

Killing or waiting will have the same effect….might as well let it run.


Hi @Mike Struening , thanks for the explanation. I simply let the job running and after some time the backup task was completed.

Userlevel 7
Badge +23

@drPhil , good question!

This is generally due to new source copy jobs that completed after the Aux Copy started (and calculated its run/completion time/percentage).

Killing or waiting will have the same effect….might as well let it run.

Reply