Exchange mailbox restore from copy precedence

  • 18 January 2022
  • 3 replies

Userlevel 1
Badge +5


I am on commvault v11 SP20 trying to restore exchange mailbox items by changing copy precedence or using a disk library from aux copy (not primary)


Restore runs fine but always picks up media agent associated with primary copy.

Tried from commcell console and command center (no option to change copy precedence in command center for exchange mailbox)


Is it expected behavior or I am doing something wrong here?


Best answer by shailu89 25 January 2022, 10:11

View original

3 replies

Userlevel 7
Badge +23

@shailu89 , if you pick the Aux Copy, it should restore from that library, though it will automatically pick the best abled MA to do the restore (of the MAs that have access).

Do you see the job IDs and streams using the preferred library (and just not the MA you want)?

Userlevel 1
Badge +5

Hi @Mike Struening 

Yes, even though copy precedence was set to different MA and library, it is picking up Primary (or best as identified by commvault)


I made my primary library offline and ran restore again. It worked and picked up aux copy data. So I suppose this is default behavior for new exchange. Although not documented anywhere.


Is it correct understanding or I am missing something here?

Userlevel 7
Badge +23

There could be more to it, though if you pick Copy 2, and the job is on Copy 2, then it should work.

To confirm, you are seeing the job being pulled from the Primary library (and not just that Media Agent)?

Would like to see the restore logs to see what is going on.  Can you share them here?  If not (security understandable) I would create a support case (and share the case number here so I can track it).