Solved

How to move data from LTO4 (from one Tape library) to LTO7 on another Tape library?


Badge +3

Hello,

I have old Tape library TS3200 with LTO4 tapes and new Tape library HPE with LTO7 tapes. I would like to copy data from LTO4 to LTO7 tapes.
I worked according documentation Media Refresh (commvault.com) .
I have Enabled Media Refresh on Storage policy copy, media for Refresh I have marked Full, and Pick for Refresh. I have run Media Refresh job and choose tab Start new media…
No, I have error “There are not enough drives in the drive pool. This could be due to drive limit set on master pool if this failure is for magnetic library.”
I don’t know where the problem is?

Is there anything else to do for Media refresh operation?

Best regards,
Elizabeta

 
icon

Best answer by Mike Struening 29 April 2021, 17:17

@elizabeta , it looks like you have a Selective Aux Copy set to NOT automatically select backups, which means you have to manually pick them.  This is why the job completes without copying any data.

What is the intent of this copy?  do you want ALL fulls, or just Monthly Fulls, etc.?

If you want to copy ALL jobs in the source, then you’ll need to create a Synchronous Aux Copy.

View original

27 replies

Userlevel 5
Badge +11

Hi @elizabeta 

It looks like you’re on the right track, but maybe LTO7 drives for your new library haven’t been configured  in the pool yet?

Please take a look at Master Drive Pools, Drive Pools and Drives - Overview

And check out Configuring Master Drive Pool, Configuring a Drive Pool.

Thanks,

Stuart

Badge +3

Hello,

Thank you Stuart for your answer.
I have ckecked this:
Old tape library have this for media
 

and only one drive


New Tape library have this:
 

 

and two drives
 


It seems ok for all drives , there is Enable Drive pool...

Badge +3

Hello,

I have found on commvault for this error
http://199.255.244.134/article/MM0074
How can I use another drive (from new Tape library whis have two) to copy data from LTO4 to LTO7 (Media refresh) ?

Go to “Expert Storage Configuration” , select your media agents and click Ok. This will show you the Libraries under Libraries Tab. Expand the Tape one and see if they all show as configured.

You should not have to configure drive per drive outside of Expert Storage if you had configured it correctly at first. 

 

Badge +3

Hello,

Everything is ok, under Expert Storage Configuration every Drive is configured ok.
So, on old Tape library i have one drive configured, on new Tape library i have two drives configured.
I have to do Media refresh copy content from LTO4 to LTO7.
When I started the Media refresh job I got an error: “There are not enough drives in the drive pool. This could be due to drive limit set on master pool if this failure is for magnetic library.”
Do I need  “to add additional DrivePools from new library to my StoragePolicyCopy?” I read it somewhere….

Best regards,
Elizabeta

 
 
Badge +1

Hello Elizabeta,

 

When using Media Refresh Feature, this has to be within the same library, you would have to have 2 MasterPools within the same library which may not be possible for the old library. It would not work if you have 2 separate libraries which is why you get that error because the Drivepool on the old library has only 1 drive. Your best bet here if your looking to condense all your LTO4 tapes into LTO7 tapes would be to make a New Aux copy which will read from the old library tapes and write to the new library, you would want to change the source of the new aux copy to the copy which is using the LTO4 tapes. You will also want to setup the new Aux copy with the Combined Stream setting to 1 to get the best utilization but since you have 2 drives on the destination, you can set it for 2 if you want faster performance copying the data.

 

Thank You

Badge

Elizabeta:

I don’t think the problem is within Commvault. I believe what you are experiencing is the inability for the tape drive to read an LTO4 tape. If I am not mistaken, an LTO7 tape drive can only read back two series. So it can only read LTO5, 6 and 7 tapes. An LTO7 drive can only write to two series back, meaning it can only write to LTO6 and 7.

Badge +3

Hello,

jzinger34

I have already copied the contents of one LTO4 tape to LTO7 with the tape to tape copy option but the problem is that the larger LTO7 tape has already been declared full. 
I would like to copy the tapes and consolidate the data with the Media refresh option. For example, I have a couple of tapes with Extended retentions (only Full backups are saved) so I would copy them to one LTO7 tape.Joey Gorana
Should I make an aux copy one for each Storage policy and then have all the tapes related to that Storage policy be transferred to LTO7 new tapes in the new library?
 
 BR,Elizabeta

 

Userlevel 2
Badge +5

Yes Elizabeta, this is the rigth way to go.

For each storage policy where you have a copy whose data path is used by the LTO4 Tape library you want to decomission:

  • Create a secondary copy(selective or synchronous) using the LTO7 Tape library. You can analyse if you want to take advantage of using Global Secondary Policy in case you have several storage policies and want to optimize the use of tapes https://documentation.commvault.com/commvault/v11/article?p=11638.htm
  • Perform the auxiliary copy operation for each storage policy from LTO4 primary or secondary copy to LTO7 secondary copy.
  • Once completed the auxiliary copy, review the jobs for the LTO7 copy and you will want to delete the copy using LTO4 media from the storage policy.

 

Badge +3

Hello,

Thanks Ledoesp for your answer.

I have question,

when I create a selective copy for a particular storage policy and for this copy select Tape library (where are LTO7 tapes)…. When I run auxilliary copy,
will I see which tapes (LTO4) are allocated for this storage policy?
Will I be able to do the data consolidation when copy data (i.e. more tapes LTO4 which are smaller to one big LTO7 tape)?Best regards,Elizabeta

 

 

 

Badge +3

Hello,

I have created Selective Copy for one Storage Policy, destination copy is Tape library which uses LTO7 tapes. Primary copy use LTO4 tape.
I have run Auxilliary copy on this Storage policy, and Job is Completed.
But, I did not see any content copied from the LTO4 tape to the LTO7 at all???

BR

Userlevel 6
Badge +14

@elizabeta , do you see any media used for this new Aux Copy?  If you right-click the Copy and select View Media, what tapes show up?

Badge +3

Hello,

@Mike Struening I don´t see any media for new Aux Copy? But job is completed.
 

 

Userlevel 6
Badge +14

@elizabeta , the screenshot you provided (thanks!) is for the Aux Copy Properties.  I’d like to see what Media is associated to the copy.

I modified the directions with the specific names here:

  1. From the CommCell Browser, expand Policies | Storage Policies | <Storage_Policy>.
  2. Right-click Copy-2, point to View, and then click Media.

    All media that is used by selected storage policy copy is displayed in the Media List dialog box.

Can you share a screenshot of the tapes this copy is using?  

Also, can you share the content on the Copy Policy and Selective Copy tabs?  It’s possible that the Aux Copy doesn’t think their is anything to copy.

Userlevel 2
Badge +5

Hi,

Mike suggested to right-click your SPcopy from the left pane, and select the View / Media associated to that copy :

View SPC Media

No Media would mean nothing was copied. So better troubleshoot the SPC settings..

 

If you have nothing, as the selective copy might be misconfigured, look at the Copy Policy tab of your SP copy, like this one : 

Make sure the Source Copy is the one from the LTO4 copy. 

Here, also make sure your backup period is not from the day you created this SPC, but from the day your old backups on LTO4 are from, otherwise, you would have nothing to copy..

Also check the Selective Copy tab settings.

Badge +3

Hello @Mike Struening and @Laurent,

I have checked option View Media for Copy-2
 


I have checked Copy Policy tab and Selective Copy for my Copy-2

 


On my Tape backup are from  year 2014….

Best regards,
Elizabeta​​​​​​​

Userlevel 2
Badge +5

OK thanks for the details.

Try also to view the media for the SPC of stored on your LTO4, to make sure you still have the data.

Are you sure that the backups were performed directly to tape and not from disk, and then copied to tape ? 

I am wondering, because I see that in the Copy Policy tab, the Source Copy is the Primary. 

So if you had like (for example) :

  • Primary to disk, with 15 days / 2 cycles ==> Data has already expired
  • Secondary copy from disk (primary) to LTO4 tape, with infinite retention ==> Data is available.

So you should create the 3rd copy like this :

  • Third copy from Secondary copy to LTO7 tapes with infinite retention

In this 3rd copy, make your all previous settings are matching what you need, and then the source copy is the Secondary.

Then, you would right-click on that 3rd SPC you just created, select View / Jobs, then make sure you unselect the time range (or select the old timerange you have data in), and in Advanced options, include also ‘Jobs that would not be copied’ to see if it’s a ‘selection’ misconfiguration or not. Then validate, click OK, and you should see the jobs.

If you see nothing, then do the same on one of the Storage Policies you are sure the target were the LTO4 tapes, go to the StoragePolicy Copy to the LTO4 tapes, and see if you have the old backups. You should have data there.

 

Userlevel 6
Badge +14

@elizabeta , it looks like you have a Selective Aux Copy set to NOT automatically select backups, which means you have to manually pick them.  This is why the job completes without copying any data.

What is the intent of this copy?  do you want ALL fulls, or just Monthly Fulls, etc.?

If you want to copy ALL jobs in the source, then you’ll need to create a Synchronous Aux Copy.

Badge +3

Hello,

@Laurent I have valid data on media LTO4. Yes, backups were performed directly to tape and not from disk.
@Mike Struening The intent of this copy is to test, and I would later make copies of the others tape from production which I have to copy...

 

I see now that is a Selective Aux Copy set to NOT automatically select backups…
Now I chosed “Automatically select Full backups at frequency”...and run Auxilliary copy.
I have run on SP “Run Auxilliary Copy”

 


Job was running, but I noticed that the LTO7 CLNU09L1 was taken.
Why was the cleaning tape taken?
I stopped Job immediately?
Then, I deleted the contents from the cleaning tape…
Why didn´t the copy take the normal new media (tape) from Default scratch?

BR,
Elizabeta
​​​​​​

Userlevel 6
Badge +14

It definitely shouldn’t take a cleaning tape, unless CV thinks it’s a regular media….in commvault, is that barcode seen as a cleaning tape?

also, the option “Start New Media” will grab a new tape EVERY time it runs.  Make sure that’s your intent if you leave it enabled.

Badge +3

Hello,
@Mike Struening now I have run Auxilliary copy (the option “Start New Media” is not checked)
Job is completed. When I go to View Media from my Copy, I see normal tape (LTO7) in new Tape library, it seems ok.
Is it normal that there exist old tape LTO4 and new tape LTO7 (copied data)?

When I have Storage policy with Extended backups, and for example 4 tapes LTO4.
I would like to copy only 2 tapes LTO4, (same Storage policy) to one LTO7 tape
I must create Auxilliary Copy also?

Will the data be consolidated on new tape LTO7? Is Auxilliary Copy actually Media Refresh option?

BR,
Elizabeta

 
Userlevel 2
Badge +5

You have a storage policy, its primary copy is using LTO4 media and secondary copy using LTO7 media. Depending on the type of secondary copy created, you have synchronous or selective secondary copy.

I think your original question was how to replace the LTO4 library and move the jobs to new LTO7 media. Creating new secondary copies using the new library and auxiliary copy all jobs to new secondary copy created, will allow you to have the jobs in new LTO7 media.

If all your storage policies are using LTO4 media in the primary copy, create synchronous secondary copies using new library. once all jobs are auxiliary copied, then you can promote the secondary copy to primary. New backup jobs will go to the new LTO7 tape library. Now you can delete the old primary copy if you want to get rid of old tape system. Our Media Refresh works at a specific storage policy copy level and it is more a tape consolidation process.

 

 

 

Badge +3

You have a storage policy, its primary copy is using LTO4 media and secondary copy using LTO7 media. Depending on the type of secondary copy created, you have synchronous or selective secondary copy.

I think your original question was how to replace the LTO4 library and move the jobs to new LTO7 media. Creating new secondary copies using the new library and auxiliary copy all jobs to new secondary copy created, will allow you to have the jobs in new LTO7 media.

If all your storage policies are using LTO4 media in the primary copy, create synchronous secondary copies using new library. once all jobs are auxiliary copied, then you can promote the secondary copy to primary. New backup jobs will go to the new LTO7 tape library. Now you can delete the old primary copy if you want to get rid of old tape system. Our Media Refresh works at a specific storage policy copy level and it is more a tape consolidation process.

 

 

 

A few months ago I added a new HPe tape library, it is now up and running, a new storage method has been created and a backup is placed on the LTO7 tapes.
The old Tape library has not yet been shut down, but we plan to do so soon.Now all that's left is to copy a few tapes from LTO4 to LTO7, since no retention came out..
Userlevel 6
Badge +14

@elizabeta , following up to confirm you now have answers to your questions.

Thanks!

Badge +3

Hello,

I have created Auxilliary copy on Storage policies with Extended backups (only Full backup) which have backups on more tapes.
I have selected Backup period

 

and Run Auxilliary copy. Data from these two LTO4 tapes (Full backup only) has been transferred to the new LTO7 tape in the new Tape library.
Everything looks ok.
Thank you all for resolving my query!

Best regards,
Elizabeta 

 

Reply