Question

Synthetic Full Backup option is not appearing ?

  • 1 December 2022
  • 12 replies
  • 90 views

Userlevel 2
Badge +8

Hi Team,

 

I Do not see the option Synthetic Full option on Vm client. Is that normal ?

Running on 11.28.32

 


12 replies

Userlevel 4
Badge +12

Hello @0ber0n 

We do support Synth Fulls for the Virtual Server Agent. It might be best to get a case open with Support to check for configurational issues.

Agents That Support Synthetic Full Backups - https://documentation.commvault.com/11.26/expert/95247_agents_that_support_synthetic_full_backups.html

 

Thank you,
Collin

Userlevel 1
Badge +3

Hi, 

In the case of manual backup triggers, we have only Full, Incremental and differential. 
Synthetic full is a process executed by the MA itself (all cumulative incrementals are combined and taken it as synthetic fulls)

@0ber0n We can’t run manual synthetic fulls from VM level.  It has to be done from vCenter pseudo client.

Badge +3

@0ber0n You can run a VM level SynthFull from the Command Center:
 

 

Userlevel 7
Badge +17

@0ber0nYou can run a VM level SynthFull from the Command Center:
 

 

Which if I recall correctly refers to the pseudo client under the respected hypervisor when looking at it from a CommCell console perspective. 

Badge +3

Yes, and it works with VSA clients which uses Indexing V2. V1 I don’t know.

 

 

Userlevel 2
Badge +8

Hi All,

Thank you for the all reponse for this topic.

Yes, I saw that we can run it from Command Center.
However, there is a situation. Think of it this way, there is 1 VM and it is backed up under two different backupsets. Let's say Backupset1 and Backupset2. When I want to run synthetic full for this VM, synthetic full is worked only for whichever backupset was last backed up with. If the last backup worked for Backupset1, synthetic full works for Backupset1. So what should I do if I want to run Synthetic Full for Backupset2? So I created the topic and hope to run synthetic for the jobs belonging to Backupset I want.

 

Best Regards.

Badge +3

You would like to run incremental backups of the same VM within two different Backupsets?
Why? Sorry, I’ve no idea for that.
I would be very surprised if you would be able to successfully restore this VM. Because I’m quite sure the CBT of the VM doesn’t recognize which backup job (/Backupset) is causing the incremental. At the end each Backupset stores 50% of the VM backup data. How to restore this?

Userlevel 2
Badge +8

Hi @Ralph 

I understood what you wanted to say.
However, because it uses Commvault V2 Index, it creates a Client for each VM and creates different BackupSets under this client. If I want to restore the VM and look at the backup history on VMInstance, I can see Incr backups after S.Full as follows. If you think this is not true, is there a config you can suggest?

 

 

Userlevel 7
Badge +17

Curious to hear why need to have it linked to two different backupsets. 

Badge +3

@0ber0n Please, do me favor and try a full VM restore out of place and then start the VM w/o network connectivity.

Userlevel 5
Badge +11

 

I have seen before why you would have the same VM in 2 Backupsets. It’s where you are using Streaming and IntelliSnap:

https://documentation.commvault.com/2022e/expert/105578_copy_operations_and_intellisnap_backups_for_vm_centric_operations.html

  • If you back up the same VM using both streaming and IntelliSnap backups, configure separate backup sets for streaming and IntelliSnap backups. If the same VM is backed up using different methods under the same backup set, browse and restore results might not be consistent.

You are right, Synthetic Full will run where the last Backup ran, so Backups need to run on both Backupsets.

You can find more details regarding Synthetic Full Backups:

https://documentation.commvault.com/2022e/expert/102092_synthetic_full_backups_for_vm_centric_vsa.html

I hope it helps.

Best Regards,

Sebastien

Reply