Commvault Command Center Dashboard Authentication Error

  • 19 August 2021
  • 9 replies

Badge +3

When loading the dashboard through the command center, loads of errors for every field say “Failed to Authenticate Token.” I’m able to authenticate through SSO but the nothing on the dashboard loads through client computer and even when trying through localhost remoting into the Commvault server (different issue). 

Has anyone experienced this or does anyone know which logs on the Commvault server to look at in order to get a place to start troubleshooting.



Best answer by AndrewArmstrong45 20 August 2021, 17:12

View original

9 replies

Userlevel 7
Badge +23

Hey Andrew,

In other cases I can see that there are issues communicating to the SQL instance. Can you check if the “SQL Server Browser” Service is running on the CommServe and webconsole server?

As part of the SQL connection, it tries to discover the instance it needs to connect to dynamically via the browser. Is you have port restrictions or if Webconsole is installed on a different network segment which could restrict UDP broadcast packets, then it could fail and throw this error.

Userlevel 7
Badge +23

Hey @AndrewArmstrong45 , thanks and welcome!  Did anything change?  When did you last log in?

You can check Webserver.log and AdminConsole.log for details, though I have some things you can check based on previous issues with this message:

  • Check under Services.msc for if SQL Server Browser Service was running or not
  • Check if the logs show that Integrated Security was enabled:



38220 122  05/15 11:47:03 (DBConnectionFactory) : attempting to connect to database url [jdbc:sqlserver://<server>;instanceName=Commvault;databaseName=CommServ;integratedSecurity=true;applicationName=CustomReportsEngine], user [sqladmin_cv]38220 122  05/15 11:47:03 (ReportsPlusCache) : SEVERE: failed to retrieve commcell datasourcesjava.sql.SQLException: Login failed for user '<username>$'.


-If it is, you can either disable the below Regkey by setting the value to '0' or you can set a Domain Account with dbo permissions on the Tomcat service




Value: 0(Disabled)

  • Check for errors in the CustomReportsEngine.log

[The connection to the host <hostname>, named instance Commvault failed. Error:" Receive timed out". Verify the server and instance names and check that no firewall is blocking UDP traffic to port 1434. For SQL Server 2005 or later, verify that the SQL Server Browser Service is running on the host.]

Confirm SQLBrowser is up and running on port 1434 as expected.

Disable Windows Firewall and AV/network protection software to ensure communication wasn't blocked.

Once CS services were restarted the information for the tiles been retrieved in logs (CustomReportsEngine.log)

The Dashboard was populated successfully

This confirms the issue is base with a firewall blocking UDP communication to the CS on port 1434

If none of the above 3 apply, share what you see in those log files.


Badge +3

@Damian Andre 

SQL is installed on the same server as Commvault but everything seems to be running except the default SQL Server Agent  (MSSQLServer). I’ve turned firewalls off on both the Commvault server and the client I’m trying to connect from. Commvault is on a different VLAN from our Admin workstations, but I pretty sure we have the VLANs talking. I’m currently working through what @Mike Struening  suggested. I found in the Custom Reporting log “The Server Commvault is not configured to listen to TCP/IP.


Userlevel 7
Badge +23

I might have the answer for you!!

Open SQL Configuration Manager, right click and select properties for the option shown below



If this is set to yes, can you please set it to no




This change will require the SQL Server service to be restarted in order to take effect.

Badge +3

@Mike Struening 

This worked for the dashboard but it was actually that the TCP/IP in the picture you showed was disabled!

Now working through some Commvault Command Center issues since thing are not loading there either. A lot of could not find dataset errors which means it is at least letting me authenticate.

I inherited this backup solution with no experience in Commvault specifically so trying to slowly navigate these errors.

Thank you for the help!

Userlevel 7
Badge +23

Welcome to the community, and to Commvault.  We’re definitely here to help!!!

That’s pretty funny :sunglasses:  Glad the screenshots helped….in effect!

Keep me posted on the rest and I’ll see how I can help.  


Badge +3

@Mike Struening I’m getting a lot of “SEVERE: Could not find dataset” for all of the fields. Seems like a SQL issue again. Any idea where to start?

Badge +3

Reboot fixed it. Sorry to bother you guys. 

Userlevel 7
Badge +23

Don’t be sorry @AndrewArmstrong45 , this is 100% what this community is about: helping each other out!  I’ll be here the next time as well :nerd: