Solved

dotnetfx3.5 dependency

  • 3 March 2022
  • 4 replies
  • 238 views

Badge +3

Why there is still dependency on dotnetfx3.5 for Commvault SQL agent ?

 

Please consider this on priority.

Why there is still dependency on dotnetfx3.5 for Commvault SQL agent ?

 

Please consider this on priority.

 

If this feature is not enabled on windows client machined our Commvault SQL agent installation is failing.

 

When this feature is enabled and then when we install Commvault SQL agent , its working and installation getting successful.

 

Why there is still dependency on older version of .netfx ?

icon

Best answer by Chris Hollis 4 March 2022, 06:00

View original

If you have a question or comment, please create a topic

4 replies

Userlevel 6
Badge +14

Because you are not on v11.16+


You need to update the environment either to SP16 or a higher. The new media kit will include the binaries without the .net 3.5 requirements. 

Badge +3

Ohh got you. 

 

SQL 2016 on client machine and Client Commvault version is v11.12 and Commserve version v11.12. So why its still requring .netfx3.5.

 

Userlevel 6
Badge +14

@Arvind Satyanarayan Bingi 

We removed dependency for .NET 3.5 a while back (SP16+).

Would need to find out what version of the software you have, what version of sql and what O/S you are running before commenting further.

Some reference material below: 

SP14: https://documentation.commvault.com/commvault/v11_sp14/article?p=3002_3.htm

SP16: https://documentation.commvault.com/commvault/v11_sp16/article?p=3011_2.htm


Thanks,

 

Chris.

Userlevel 7
Badge +23

@Arvind Satyanarayan Bingi , I saw you reached out to support on this and spoke to Jason.  Were you able to get an answer or create an incident for this question?